Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Ubuntu 12.04 desktop virtual machine ran by VMWare and having some issue with the GUI clock/time what ever it is called. The thing in the right corner showing the time.

When I put the laptop in sleep mode, it does not put the virtual machine to sleep nor suspend it and when I reopen the laptop, the same day or the following day, the clock is still at the time of the sleep mode action. Eg: I put the laptop to sleep at 4:45 PM, when I reopen it, the virtual machine is still at 4:45 PM, and will stay like that until... something.

I've found a way to "fix" it by going to the date and setting and just pressing ok, and then it synchronizes it within the next 5-10 minutes. But still it annoys me and I was wondering if there is a way to force the GUI clock to synchronize. From my setting it is synchronized with Internet but it does not synchronize often and having to go to the settings, and then having to wait at least 5 mins kind of annoys me.

So I was wondering if there is a way to force the synchronization from command-line?

I do have read this post but that wasn't the same problem and that was the closest question I found that was a bit similar to mine.

share|improve this question
    
    
@JorgeCastro My machine hasn't been suspended though, as I state in my question. The VM stays active... I mean, I often don't even have to write my password to gain access back to it. Even though the laptop has been sleeping for a few hours. –  Hugo Dozois Mar 1 '13 at 0:58
    
Aha! This might be it! stackoverflow.com/questions/276965/… –  Jorge Castro Mar 1 '13 at 1:03
    
@JorgeCastro This could work, I'll test when I can test it as it doesn't always happen, but would still be fun to have a command-line option to force synchronization haha! –  Hugo Dozois Mar 1 '13 at 1:10
add comment

1 Answer 1

up vote 0 down vote accepted

As found by Jorge Castro, the problem is related to the synch rate of VMWare Tools. The synch rate is set to false by default in the settings.

It can be solved by setting :

tools.syncTime = true

in the VMNAME.vmx file.

You can also set numeric values in second for specific rate. The value true defaults to the numeric value 60 (or one minute).

See this Stack Overflow question for more information.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.