Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Dropbox works well, but often the tray icon starts spinning forever with the tooltip message "Saving 1 file..."
I usually don't worry about it, and I never had any loss, despite switching computers often. An easy solution is to restart Dropbox, it spins for a second before the tooltip says "All files up to date".

But how to permanently prevent this problem?

Ubuntu 2010.10
Dropbox 0.7.110
Dropbox stores about 50 text files, 1 MB in total.

share|improve this question
up vote 2 down vote accepted

This worked for me, you give it a try:

If unlinking and relinking your account doesn't solve the issue, your settings may be protected or inaccessible due to a permissions problem. If this is the case, you can remove your settings by hand using an administrative account. Here's how:

On Linux

  1. Quit Dropbox by right-clicking on the Dropbox menu from the menu bar and selecting Quit
  2. Open a terminal and copy and paste the following line into the terminal (exactly as written below):

    sudo rm -rfI ~/.dropbox

  3. You will be asked for your password to confirm the folder's removal

  4. Restart Dropbox from the Applications > Internet menu

Once Dropbox loads, the application will rebuild your settings files and you will be asked to relink to your account.

Note: We're working on a way to check and fix your Dropbox installation automatically from within the application. Stay tuned...

(From the Dropbox Help Forum Team)

share|improve this answer
I just unlinked and relinked, I will let a few days pass to judge whether the problem reappears or not. – Nicolas Raoul Feb 15 '11 at 7:22
The instructions of the dropbox team isn't to simply unlink and relink. You should remove a folder in order to allow your dropbox to make a new configuration of your dropbox when relinking. Which seems to have some sense since it works. In my experience: I waited 2 weeks until I found this solution. Good luck my friend! – Geppettvs D'Constanzo Feb 15 '11 at 19:34
OK, I also ran this command. Will come back for feedback in a few days. – Nicolas Raoul Feb 17 '11 at 5:58
I removed the folder, reinstalled completely, and still the same problem. – Nicolas Raoul Mar 2 '11 at 3:23
Problem does not occur anymore with recent versions. Accepting highest-voted answer. – Nicolas Raoul Jun 15 '12 at 6:56

Go into the folder with nautilus and see which file is not being updated. The icon has a blue symbol with two white arrows inside. Check if you have enough privileges to read the the file. I would also update to the latest client version, which is 1.1.35.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.