Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am following these instructions (Mouse Compile Instructions) to try to get my ALPS touchpad working, but I get this error on the make command.

sudo make -C /lib/modules/`uname -r`/build M=`pwd` psmouse.ko
make: Entering directory `/lib/modules/3.5.0-17-generic/build'
make: *** No rule to make target `psmouse.ko'.  Stop.
make: Leaving directory `/lib/modules/3.5.0-17-generic/build'

I first got an error saying the build directory didn't exit. I created it, but still got the above error. Can someone suggest something to try next? I am stuck.

share|improve this question
    
I should mention, too, that I first tried without the sudo prefix. –  EdgeCase Mar 1 '13 at 0:14
    
Is linux-headers-generic installed? If not, run sudo apt-get install linux-headers-generic. –  Eric Carvalho Mar 1 '13 at 0:20
    
Thanks. I tried your suggestion, but still the same error. Tried linux-source, too. Appreciate the help. –  EdgeCase Mar 1 '13 at 0:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.