Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an nVidia GeForce 9600 GT with dual DVI connections in a desktop computer.

Scenario 1:

DVI-1 is connected via DVI cable to a 22" Samsung panel. Ubuntu 12.04.2 64-bit is running successfully. At/after installation, by default the "post-release-update (version current-updates)" restricted nVidia driver was installed and working.

Scenario 2:

After shutting down the computer, I moved the 22" to DVI-0 and added a 19" LG onto DVI-1. This monitor only has a VGA connector, so I used a DVI to VGA converter. I booted the machine and the BIOS, etc. appeared on the 22", as did the Ubuntu logon screen. The 19" showed a wallpaper without any logon, just at the wrong resolution. After logging in, I went to Displays and adjusted the resolution for the 19". The closest is 1360x768. The monitor's native resolution (I pressed auto-adjust on the monitor to confirm) is 1366x786. The display is not crisp -- it's showing the standard blurriness when not at the native resolution. The 19" appears in Displays as "Unknown", even after pressing "Detect Displays". The cable is not loose and I tried with a different VGA cable. Also, moving windows around on the 22" is now creating visual tearing. All in all, it's not worth the effort at the moment...

Question:

To set the correction resolution for the 19", am I back to manually hacking multiple-monitors via xrandr each time I boot and/or fiddling around with different nVidia drivers?

share|improve this question

1 Answer 1

You should have a file in /etc/X11/ named xorg.conf. If it is not present, you have to generate one using sudo nvidia-xconfig. After you made sure that your xorg.conf is present follow these steps:

1- Open a terminal window and type sudo nvidia-settings.

2- On the first dialogue that appears, make sure that your 19" monitor is selected, then press the advanced button to reveal the custom resolution box.

3- enter your desired resolution and click save, if it asks for merging both xorg configs, press yes.

4- Reboot.

5- If it is still not fixed you have to manually configure the xorg.conf file, you can find the resolution section somewhere in the file.

share|improve this answer
    
There is no custom resolution box under Advanced. –  SabreWolfy Feb 28 '13 at 20:23
    
sorry I can't tell you the exact location, but advanced is a button that you press it and a text box appears that you can modify the resolution, I think you should go to the second option from the top in the left pane. –  Soroosh129 Feb 28 '13 at 20:27
    
I have the "Advanced" button. There is a space called "Panning" where I can enter text...? –  SabreWolfy Feb 28 '13 at 20:30
    
As I expected, entering a custom resolution into the Panning field did not work. –  SabreWolfy Feb 28 '13 at 20:35
    
Yes, as I expected too, please do it manually. and also you can put the xrandr command in the /etc/rc.local file. It will run this automatically when your system boots. –  Soroosh129 Feb 28 '13 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.