Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to control the dimensions of my Ubuntu Desktop. Currently the files I download onto the Desktop do not seem visible, as the Desktop extends well below what's displayed on the screen. I have attached a screenshot where the filename of the bottom-most file (and several files under that) is cut off.

Is there a setting which I can change?

Ubuntu Desktop

xrandr output:

enter image description here

share|improve this question
    
@BrunoPereira: No copy/paste, just downloading from the Net onto the Desktop. This screenshot is after I right-click and choose "Organize Desktop by Name" - the icons get arranged in a long straight line that extends below the Desktop. –  Bravo Feb 28 '13 at 17:33
    
ok, clear, weird thing :( –  Bruno Pereira Feb 28 '13 at 20:01
    
@Shyam what is the output of xrandr? –  Salem Mar 4 '13 at 0:41
    
Hi @shyam please pardon me if i'm asking you a far irrelevant question. First thing is have you tried auto-adjustment button which will be provided in your monitor. And second thing is the wallpaper looks very familiar is it animated wallpaper or changing desktop like that? If it is so then definitely your screen exceeding problem is because of that wallpaper. –  learner Mar 4 '13 at 11:04
1  
Hey @shyam you can just copy and paste it as text or take a snap-shot as you did for your desktop screen. –  learner Mar 4 '13 at 14:49

3 Answers 3

up vote 3 down vote accepted
+50

I have tried a setup like yours and the problem seems to be the fact that the screens are not "aligned". Probably because the 17' one is under a little Unity/Nautilus treats it as more space.

I don't know if this is normal or is a bug in either Unity or Nautilus, but to me it seems a normal behavior. To fix it just align both displays as in the following picture:

enter image description here

So just drag the second monitor on "Display" settings until they are somehow aligned. Also note that the disposition of both screens seems to matter, so if you put 27' screen on top of the 17' one the icons that do not fit on the first go to the second one. If that's what you want keep them aligned but with this disposition:

enter image description here

After applying the new setup you need to order the icons again in Nautilus.

share|improve this answer
    
Thanks Salem. You are mostly right except that the alignment had to be as in this picture here. In that case, the files in the bottom reach the smaller desktop. –  Bravo Mar 4 '13 at 17:19
    
If you have the privileges, could you add the tinypic images to stackexchange? The question and the discussions will be self-contained then. –  Bravo Mar 4 '13 at 17:20
    
I think I can't do that (the comments at least), but updated the answer with the setup you referred. –  Salem Mar 4 '13 at 17:30
4  
BTW a tip: when you need to provide the output of a program like xrandr you can use pastebinit to save you some time: it will read all the text it receives and store it publicly at paste.ubuntu.com, providing you a link. Example: xrandr | pastebinit –  Salem Mar 4 '13 at 17:38

Your screenshot is actually helpful, especially the line Screen 0: ... current 3200x1533. That tells you the screen size according to xrandr is 3200x1533. You can reset this using xrandr with the --fb option. In your case you could try xrandr --fb 1280x1024. Normally that value is supposed to be the smallest of the resolutions of your different displays.

For more information, see the man xrandr page:

   --fb widthxheight
          Reconfigures the screen to the specified size. All configured monitors must fit within this size. When this option is not pro‐
          vided,  xrandr  computes  the smallest screen size that will hold the set of configured outputs; this option provides a way to
          override that behaviour.

   --fbmm widthxheight
          Sets the reported values for the physical size of the screen. Normally, xrandr resets the reported  physical  size  values  to
          keep the DPI constant.  This overrides that computation.
share|improve this answer
    
Thanks. Output: xrandr --fb 1280x1024 xrandr: specified screen 1280x1024 not large enough for output VGA1 (1920x1080+0+0) –  Bravo Mar 4 '13 at 16:24
    
The output for 1280X1024 cut the pic in half and the right side of the Desktop was black. –  Bravo Mar 4 '13 at 16:24
    
can you try xrandr --fb 1920x1080? –  don.joey Mar 4 '13 at 16:25
    
xrandr: specified screen 1920x1080 not large enough for output "DP1 (1024x768+1920+509)" –  Bravo Mar 4 '13 at 16:26
    
you could try a really large value and see whether it tells you what the maximum value is, but before: what is it that you have connected as graphical device? A projector? –  don.joey Mar 4 '13 at 16:31

Do you have two monitors attached? In any case have you tried to to click "System Settings" and then "Displays"? That dialog window should tell you something about the attached monitor and the resolution currently configured for it. If not already showing this, try to choose the resolution 1280x1024 there. Or please report back what that dialog shows.

share|improve this answer
    
Yes, I use two monitors and the 23'' is what I have posted. The display output is here. And anything less than 1920X1080 looks awfully big on screen. –  Bravo Mar 4 '13 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.