Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed Gnome Shell and changed the theme and so on; but I can't change the wallpaper.

I'm using the Gnome Control Center to change the wallpaper but it doesn't work even if i usegconftool and programs like Wallch aren't working either.

On Unity it's the same problem, but on Unity I can change my wallpaper with Compiz wallpaper changer plug-in.

Any ideas how to fix it?

I don't know what program draws the background, but Nautilus isn't. If i know which program it is I can try killing it to use Wallch, but I haven't found any hints which program is used.

share|improve this question
    
Nautilus draws the desktop on both Unity and Gnome Shell you can verify that by terminating the process completely and it will result in your desktop icons disappearing and you not being able to right-click the desktop. How are you killing Nautilus?. Have you installed Gnome Tweak Tool and selected let Filemanager handle Desktop?. – Uri Herrera Feb 28 '13 at 19:41
    
cool thanks, after re-enabling let file-manager handle desktop it worked again... and i've tried to kill nautilus by typing killall nautilus won't work, but it's good enought for me to change the wallpaper :D – tom. Feb 28 '13 at 22:29
    
Is there a way to change the background without having the file manager to managed the desktop? I don't want neither desktop icons nor nautilus running. Thanks – the brx in the walls Oct 30 '13 at 8:59

In my case, enabling

Icons on Desktop

(first option in Desktop section of the gnome-tweak-tool) did the trick.

share|improve this answer
1  
Me too. Why is that? – 147pm Sep 22 '15 at 18:16
1  
Worked for me, too. I previously had Gnome 3 installed, and I'm currently using Unity. It may have something to do with this, at least in my case. – Chester Mar 19 at 14:21
    
Yeah i was just trying things and searching when this clicked, no idea bout the reason and I no longer use gnome, unity is better for me. – R T Mar 21 at 6:45

Nautilus handles the desktop in both Unity and Gnome Shell, to make sure you have this activated do the following:

  • Download Gnome Tweak Tool sudo apt-get install gnome-tweak-tool
  • Open it and select Desktop then activate Have file manager handle the desktop by clicking the switch. image
  • Log out.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.