Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in ubuntu 11.10 on a macbook pro 7.1 i just removed unity and installed back gnome, everything is working perfectly but the desktop. Looks like i can't right-click on it, (while i can on panels and menu), not even with ctrl+alt+right-click and if i $touch something, it creates something but it does not appear in desktop view ( the one with background ).

It's not fundamental but would be nice :) Thanks

ps: I know it's probably a common issue and I searched but its rather difficult to find something, since all keywords refers also to gnome-desktop, and install only related issues are shown :/

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Try these commands in terminal:

gsettings set org.gnome.desktop.background draw-background true
gsettings set org.gnome.desktop.background show-desktop-icons true
share|improve this answer
    
thank you! quick and effective. –  jalone Mar 1 '13 at 2:39
    
I get lots off error text when trying this : dconf-WARNING : failed to commit changes to dconf: Error spawning command line 'dbus-launch --authlautnch=...' < same with sudo –  IanVaughan Oct 19 '13 at 20:48
add comment

That's a feature of Gnome 3. You can't right click on or put files/shortcuts on the desktop. It's supposed to be less cluttered/distracting. Quickly googling the issue will find you some tutorials on how to enable that functionality.

share|improve this answer
    
thanks for the explanation, voted Bal since answer was quicker. –  jalone Mar 1 '13 at 2:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.