Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm using a laptop with built-in touch-pad that works in Windows 7. But after I switched to Ubuntu 12.04 LTS, it's not working now.

share|improve this question
can you check whether it is on? more info here:… – don.joey Feb 28 '13 at 12:05
I have enable it, but it's still not working. – Herks Feb 28 '13 at 12:11
I had a similar issue on 12.04.02. Press Ctrl+Alt+T to open a terminal and paste those commands to check if they solve your problem: sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps – Salem Feb 28 '13 at 13:19
Thanks, it's working now. – Herks Feb 28 '13 at 13:20
@Salem please turn your comment info an answer.. – don.joey Feb 28 '13 at 14:08

1 Answer 1

up vote 47 down vote accepted

This seems to be a bug in 12.04.2. As stated in comments, a simple fix would be unloading the mouse driver and load it again like this:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

This only keeps the touchpad working on this session. To make it permanent one can create a file like /etc/modprobe.d/psmouse.conf (you can choose the name you want, but you must keep the extension) with the following content:

options psmouse proto=imps
share|improve this answer
Yess! Had same problem and using Google came here and this solution worked. Thanks! – Tõnu Samuel Sep 14 '13 at 5:03
Works perfectly in my asus! Thanks! – thameera Sep 24 '13 at 17:55
This still happens in 14.04 but this fix still fixes it although I can't get it to execute on start of the machine so I am currently stuck running it manually each time... – Ed Bishop Mar 4 at 16:40
This just helped years late on Ubuntu 15.10 – Andrew Nov 7 at 3:13

protected by Community Sep 2 '13 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.