Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've seen some other topics with similar issues, but being a 'bit' of an Ubuntu newb, I wanted to address my concrete problem, to solve this properly, because I'm not sure do some other solutions apply in my case.

Here it goes, my Update Manager started working, and surfing on the internet, I completely forgot it was turned on. I couldn't access some sites due to flash player being updated, but as I've forgot that updates were ongoing (flash included), I thought I had to do it manually. So I went to this site: http://www.linux.org/article/view/install-adobe-flash-reader-air-in-ubuntu-12-04-precise-pangolin-

I've entered these two codes:

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner" 

sudo apt-get update && sudo apt-get install flashplugin-installer acroread 

Then I noticed my update manager working, alas too late. It froze in its process, so I logged off, and logged in, entering the update manager again. It asked me to do a partial upgrade, I accepted, and since then when I click "check for updates" I receive a warning with following details:

W:Failed to fetch http://archive.canonical.com/dists/&(lsb_release/-sc)/source/Sources  404  Not Found [IP: 91.189.92.150 80]
, W:Failed to fetch http://archive.canonical.com/dists/&(lsb_release/partner/source/Sources  404  Not Found [IP: 91.189.92.150 80]
, W:Failed to fetch http://archive.canonical.com/dists/&(lsb_release/-sc)/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]
, W:Failed to fetch http://archive.canonical.com/dists/&(lsb_release/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Can anybody help me with some step-by-step instructions for Ubuntu dummies to solve this? :)

To save what left of my virtual dignity, I'm guessing I need to reset those repository-source-code-thingies for flash, to set it to default, but I don't know how to do that, or is that the solution in the first place.

Edit: I went to Update Manager settings and unchecked updates from independent sources, that made the warning not to appear. I'm not sure will it affect some of my other applications.

share|improve this question

1 Answer 1

Run lsb_release -sc in a terminal, remember the output.

then edit /etc/apt/sources.list (e.g. by running sudo gedit /etc/apt/sources.list) and edit those 4 lines, replacing &(lsb_release/-sc) with the previous output.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.