Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Lenovo z570 laptop with 750GB HDD, 6GB RAM, Intel i5 Processor and Windows 7 installed in it. I also have an external portable USB hard-disk of 1TB.

My aim was to install Ubuntu 12.10 onto the external hard disk including Grub boot loader onto it too.

I use my external hard disk to store my backup data. In order to install Linux onto it I made some free space in the hard about 50 GB using Windows partition tool. I successfully did it without loosing any data.

Then I downloaded Ubuntu 12.10 32bit ISO, made an boot-able USB, and I booted into Ubuntu successfully. I then went on with installing Ubuntu. I carefully selected my 1TB external hard disk found out the free space I had created earlier, and made 4 partition on it

1.  \boot    ext4   1024 MB
2.  \        ext4   5120 MB
3.  swap            6144 MB
4.  \home    ext4   32768 MB

And I selected \boot partition to install GRUB into it.

and everything went on smoothly.

When I restarted the computer after installing Ubuntu it directly loaded Windows 7. So I restarted it, changed the boot priority to USB HDD and when I booted into it, it showed the next error:

ntldr missing
Press Ctrl+Alt+Del to restart
share|improve this question
    
The problem is that your computer is not booting from the USB stick. Because ntldr is a boot loader for Windows. –  Lucio Mar 19 '13 at 19:32
    
The GRUB should be installed in the MBR of the 1TB external hard drive, not in the /boot partition within. With 38GB of free space for Ubuntu, I think it may be better to create just one / ext4 partition and keep the swap as is. The way you set it up the /boot and / will fill up when you start adding updates and applications. –  user68186 Mar 19 '13 at 20:32
    
I'm not sure why this is being nominated for closing. Problem is clear and should be solved by answers (even if no accepted answer). –  belacqua May 28 at 1:02

2 Answers 2

You need to go into your bios and make sure USB booting is enabled, after that when your computer starts up it should say something along the lines of "select boot device hit f12" or something, press that, then select your external hard drive from the list.

That should do it.

share|improve this answer

The problem is that your computer is not booting from the USB stick. I can confirm this because ntldr is a boot loader for Windows.

Possible reasons:

  1. You didn't choice to boot from the USB flash drive correctly or
  2. The GRUB was installed wrong.

Possible solutions:

  • Just turned on the PC enter in the BIOS and select the USB device as the first option to boot.
  • Repair the GRUB
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.