Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed SSL (stupidly) to encrypt the data being sent, the only trouble was my subdomain was redirecting to my main. I changed my default virtual host back to the original settings and also ran a2dismod ssl. Now when ever I type in www.domain.com it redirects to https://www.domain.com and then says SSL Connection Error.

I'm hoping to either get SSL working on the main+sub or just remove completely. Has anyone got any idea why it's redirecting to Https?

My VirtualHosts file is:

<VirtualHost *:80>
ServerName www.domain.com
DocumentRoot /var/www/folder
#SSLEngine on
#SSLCertificationFile /etc/apache2/ssl/apache.crt
#SSLCertificationKeyFile /etc/apache2/ssl/apache.key
</VirtualHost>

<VirtualHost *:80>
ServerName sub.domain.com
DocumentRoot /var/www/sub
#SSLEngine on
#SSLCertificationFile /etc/apache2/ssl/apache.crt
#SSLCertificationKeyFile /etc/apache2/ssl/apache.key
</VirtualHost>

Now if I un-comment the lines with # on and change *:80 to *:443 it redirects to the main site with SSL enabled...

share|improve this question
    
Is this question appropriate for Askubuntu? I might suggest moving / reposting your question to Stackoverflow.com or Serverfault.com. –  kalaracey Feb 28 '13 at 0:28
1  
It's on a UbuntuServer so I assumed so? –  Jake Feb 28 '13 at 0:32
    
@kalaracey Questions about services on Ubuntu fall well within what's considered on-topic here. Also, please note that even if a question is on-topic elsewhere or potentially better elsewhere, that doesn't make it off-topic. –  Eliah Kagan Feb 28 '13 at 6:00
    
@EliahKagan Alright thanks! Then if it is not off topic, I might suggest moving it to Serverfault.com –  kalaracey Mar 2 '13 at 19:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.