Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Obviously a step by step guide would be very helpful please as I'm new to this inputting code lark.

I had a wireless connection when I installed ubuntu 12.10 from the cd once it installed it suggested there was 126 updates so I installed those and my wireless connection has stopped.

I've tried looking at other posts but find that I end going round in circles, what I'm after is the answer in a step be step format without having go around the houses looking at a thousand other posts with similar problems.

Below is what popped up in the terminal hopefully theres some kind person out there that understands what the problem is....

bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb) ...
Removing all DKMS Modules
Done.
Unpacking replacement bcmwl-kernel-source ...
Setting up bcmwl-kernel-source (5.100.82.112+bdcom-0ubuntu3) ...
Loading new bcmwl-5.100.82.112+bdcom DKMS files...
Building only for 3.5.0-25-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules
ERROR: Module ssb does not exist in /proc/modules
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module brcm80211 does not exist in /proc/modules
ERROR: Module brcmfmac does not exist in /proc/modules
ERROR: Module brcmsmac does not exist in /proc/modules
ERROR: Module bcma does not exist in /proc/modules
FATAL: Module wl not found.
FATAL: Error running install command for wl
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-25-generic

Thanks for your help

John

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You could try to disable driver for your wireless card in Settings -> Source Software -> additional drivers (sorry if the path is not correct, i have Ubuntu in italian) and then restart. For me it worked.

share|improve this answer
    
Hi Sasha how do I do that? –  Jfhun Feb 27 '13 at 22:58
    
Search for Ubuntu Software Center, then go to Modify and at the bottom you will find Source software. Go under the menu Additional drivers and try to disable the drivers for your wireless card. –  Sasha Alexandru Podgoreanu Feb 27 '13 at 23:05
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

This means that kernel headers are required but missing to build this driver. Please get a temporary wired ethernet connection and do:

sudo apt-get install linux-headers-generic
sudo apt-get install -reinstall bcmwl-kernel-source
sudo modprobe wl

You should be all set.

share|improve this answer
    
Chili555 You are a true hero thank you so much I am wireless and happy! –  Jfhun Mar 2 '13 at 17:19
    
Glad it's working. –  chili555 Mar 2 '13 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.