Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new MSI GT70 with windows 8, which has the new UEFI settings, and it just won't install ubuntu 12.10. I have tried a lot of different options to try and install it. I have tried using nomodeset and acpi=off,but everything has failed. I have even tried going into the bios and turning off fast boot, secure boot, and switched it over to legacy mode. All have got me somewhere in the installation, but it will not actually install ubuntu. By the way I have been using a CD.

At first when I just tried to install ubuntu without any special stuff from the bios, a screen with four options would appear. The top option was try ubuntu without installing, then install ubuntu, then OEM, and finally check disc for defects. Any option I hit enter on would cause my computer to just go to a black screen.

Next I tried to switch the bios settings to turning off fast boot, secure boot, and switching it to legacy mode. After I did this, I got the furthest with the installation, but it still failed. What happened was, it brought up a new ubuntu menu where six items appeared. They were the same as before with two additional ones that said boot from first hard drive and something else I cannot remember.If I entered into any of these options, it would display a bunch of code in like a command prompt, but then at the end, it would go to a black screen yet again.

My computer has two internal drives on it, one 128gb SSD and another 750gb HDD. Let me know if you need anymore info. I really need to install ubuntu for school. Someone please help. Thanks in advance.

share|improve this question
I have already done everything that tutorial has said and still no correct installation. – GolfinGamer Feb 27 '13 at 22:40

You have to use amd64 version of ubuntu. You can get it here. From the same link:

Have a new PC with the Windows 8 logo or using UEFI firmware?
Please use a 64-bit flavour of Ubuntu desktop.

Full reason here for it to only work with the 64bit version.

share|improve this answer
I am using 64 bit windows 8 and using a 64 bit ubuntu disc – GolfinGamer Feb 27 '13 at 22:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.