Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 12.04 on my Toshiba Satellite C855 and cannot connect to any wireless networks. When I run lspci in Terminal, it shows:

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

I have tried downloading the Broadcom STA wireless driver, and it shows as activated in Additional Drivers, but it doesn't seem to be making a difference. Please help!

share|improve this question
Why do you try the BroadCom driver when lspci shows you have a Realtek? – guntbert Feb 27 '13 at 18:08
Weird how the Additional Drivers would offer you a Broadcom STA driver when infact you have a Realtek adapter... – oaskamay Feb 27 '13 at 18:37
Did your wireless work fine at fist install, and then quit after an update? – Shadow Codex Feb 27 '13 at 18:53
My wireless hasn't worked since I have installed Ubuntu – Justin Smith Feb 27 '13 at 20:01
Also, I have no clue what I am doing. Contrary to what my friends may think, I am no tech wizard and in fact this is my first time using Ubuntu. Simple instructions would be very helpful if anyone can find a solution. – Justin Smith Feb 27 '13 at 20:13

first, in the terminal run:

sudo apt-get install linux-headers-$(uname -r) build-essential

It's probably a good idea to remove the broadcom stuff:

sudo apt-get remove --purge bcmwl-kernel-source

download your driver from the Realtek site (RTL8188CE)

scroll down to the Unix(linux) section, make sure you download the driver for the kernel 2.6.24 (and later). Select the mirror closest to you, and save the downloaded archive in your Downloads folder. Right-click and select "extract here".

in the term run

cd ~/Downloads/rtl_92ce*
sudo su
make install

Wait for magic to happen. Reboot. Hopefully enjoy working wifi. Report back

share|improve this answer
make -C /lib/modules/3.5.0-25-generic/build M=/home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207‌​.2013 modules make[1]: Entering directory /usr/src/linux-headers-3.5.0-25-generic' CC [M] – Justin Smith Feb 28 '13 at 0:32
/home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2‌​013/base.o CC [M] /home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2‌​013/rc.o CC [M] – Justin Smith Feb 28 '13 at 0:33
/home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.‌​2013/debug.o CC [M] /home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2‌​013/regd.o CC [M] /home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2‌​013/efuse.o CC [M] /home/justin/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2‌​013/cam.o CC [M] – Justin Smith Feb 28 '13 at 0:34
and a lot of other stuff that I don't really find a point in putting into comments. after which it left me with: justin@justin-Satellite-C855:~/Downloads/rtl_92ce_92se_92de_8723ae_88ee_linux_m‌​ac80211_0012.0207.2013$ and nothing had changed. – Justin Smith Feb 28 '13 at 0:38
did you reboot? If yes post output of lspci -v | grep -iA 10 'network' and lsmod – phipsalabim Feb 28 '13 at 2:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.