Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Computer: Acer Aspire 7730. Only Ubuntu installed.

Hi, I installed Ubuntu 12.04 yesterday and WiFi worked out of the box. But now the WiFi does not work anymore. It was after I did a

sudo apt-get update

in order to try to fix Spotify (native) (couldn't start it), but I've since learned that update does not actually update any packages (correct me if I'm wrong). But if was after the reboot (Ubuntu wanted me to reboot) that my WiFi no longer works.

If I type

sudo lshw -c network

This is the output:

   *-network UNCLAIMED     
       description: Network controller
       product: WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:c0a00000-c0a01fff

So my WiFi adapter is unclaimed, which I've read means that no driver is associated with it.

Also:

iwconfig

gives

lo        no wireless extensions.
eth0      no wireless extensions.

This is the link that I wanted to use to try to install iwlwifi (I first wanted to try a Linux driver instead of the whole Windows wireless Driver thing. Plus when I tried to find the driver for this adapter, I could only find .exe files, while it said that I should find .inf files).

Running this

cd /lib/firmware
ls *.ucode

gives

iwlwifi-1000-5.ucode  iwlwifi-2030-6.ucode  iwlwifi-6000-4.ucode
iwlwifi-100-5.ucode   iwlwifi-3945-2.ucode  iwlwifi-6000g2a-5.ucode
iwlwifi-105-6.ucode   iwlwifi-4965-2.ucode  iwlwifi-6000g2a-6.ucode
iwlwifi-135-6.ucode   iwlwifi-5000-5.ucode  iwlwifi-6000g2b-6.ucode
iwlwifi-2000-6.ucode  iwlwifi-5150-2.ucode  iwlwifi-6050-5.ucode

Notice the iwlwifi-5000-5.ucode. This looks very similar to the file(s) that I downloaded from the previous website that I showed. So since it is already there, I haven't tried to install it to that directory yet (and I'm not quite certain how to do it). Maybe the kernel/system/whatever simply doesn't load the driver on boot-up?

Most of the problems I've had with Ubuntu so far have been solved with copy pasting terminal commands without knowing what they do, but it feels like the more I do this the more brittle the whole system becomes (because I don't know what I'm doing). It seems that installing and updating software can lead to unforeseen, bad side-effects that I don't have the skill to foresee. So for this problem I want to ask someone directly before I proceed.

Thanks!

share|improve this question

2 Answers 2

The driver for your card, iwlwifi, is already present in the 12.04 kernel, as is the required firmware. Let's load it and see if your wireless springs to life:

sudo modprobe iwlwifi
iwconfig

Did a wireless interface wlan0 get created? If not, check the message logs to troubleshoot:

dmesg | grep iwl
rfkill list all

The pipe symbol | is on the right side of my US keyboard on the same key with backslash.

share|improve this answer

Your problem looks similar to mine, and I think the new kernel and broadcom drivers are the problem. I ran this, restarted, and it fixed it:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

If that does not work then you can look at these two links for some other ideas:

If you use the #6 solution please also run the commands found at this link:http://ubuntuforums.org/showthread.php?t=1966012#9

Hope this helps!

share|improve this answer
    
The first command: says that it is already installed. The second: doesn't succeed. Here is the last part of the output: > DKMS: Install Failed (depmod problems). Module rolled back to built state. dpkg: error processing bcmwl-kernel-source (--configure): subprocess installed post-installation script returned error exit status 6 No apport report written because MaxReports is reached already Errors were encountered while processing: bcmwl-kernel-source E: Sub-process /usr/bin/dpkg returned an error code (1) Havent tried the third –  user136104 Feb 27 '13 at 17:58
    
I edited the answer with some additional things to try. –  CodeTheUniverse Feb 27 '13 at 18:11
    
Most of the various commands in the links seem to give errors. It seems that something that comes up a lot is complaints about the wl module in some form, for example "FATAL: Module wl not found". I tried to install it with apt-get, but that mentioned emacs so I'm guessing it's the wrong package. Any ideas about what I should do about this wl module? –  user136104 Feb 27 '13 at 18:51
    
I'm out of ideas :( You might benifit from a fresh install. Especially since you have only had it installed for a day. –  CodeTheUniverse Feb 27 '13 at 18:55
    
@chili555 because I have an intel card as well, and those commands are the only thing that fixed it. Please do not join a question just to bash. Thank you. Have a nice day. –  CodeTheUniverse Feb 27 '13 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.