Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up correct display resolution but the driver doesn't seem to work.

r00ster@nix:~$ sudo lshw -C display
[sudo] password for r00ster: 
  *-display UNCLAIMED     
   description: VGA compatible controller
   product: MGA G200e [Pilot] ServerEngines (SEP1)
   vendor: Matrox Electronics Systems Ltd.
   physical id: 0
   bus info: pci@0000:09:00.0
   version: 05
   width: 32 bits
   clock: 33MHz
   capabilities: pm pciexpress msi vga_controller bus_master cap_list
   configuration: latency=0
   resources: memory:ea000000-eaffffff memory:d0810000-d0813fff memory:d0000000-d07fffff memory:d0800000-d080ffff

I've installed xserver-xorg-video-mga but current driver seems to be:

Driver        Gallium 0.4 on llvmpipe (LLVM 0x301) 
Experience    Fallback

Screen is detected as Laptop and maximum resolution is 1280x1024. How to fix that?

EDIT:

Here is my Xorg.0.log

And here is my xorg.conf

share|improve this question

The old version of the X Windows 2d acceleration software, XAA was disabled and removed from the Xorg server, unfortunately the mga driver does not support the new method of doing 2d acceleration...

You can see that in your Xorg.log file:

...
[    81.014] (WW) MGA(0): Not supported by hardware, not initializing the DRI
...
[    81.015] (WW) MGA(0): Direct rendering disabled
...

In the meantime try changing the Driver setting in your xorg.conf file to "vesa" and remove the BusID line.

You won't get acceleration but it may work better.

Looking at the code for the mga driver on freedesktop.org there has ben some work on making it work better, this might be relevant:

https://cgit.freedesktop.org/xorg/driver/xf86-video-mga/commit/?id=da1223394ac9b6f3974b0b2570cbf46a2425fc11

So it's possible that the latest version of the mga driver will be better.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.