Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just switched modem from an older Netcomm router / modem after power supply failed.

Old router - NetComm NB9WMAXX

New Router - Netcomm NB16VW

I've configured everything the same on the new router and all my other devices connect to wifi with no issues (Win7 laptop, iphone, ipod, other Ubuntu PC).

Note the other Ubuntu PC is 12.04 and has an external USB wifi dongle.

However, my HP Mini 210 1100 will not connect although obviously had no issues with the previous modem / router.

It can see all networks OK and when I try to connect to mine, I am prompted for a passkey. However it seems to attempt connection several times before timing out and dropping the connection.

I'm guessing it's either failing authentication or the DHCP step. The machine does not appear in the DHCP client tables at any point and does not acquire an IP address.

I ran a shell script provided by Wild Man (one of the Ubuntu forum moderators) on each machine and have published each on Ubuntu One.

Not working HP Mini: http://ubuntuone.com/6zrjqJNi67uHfOyDUtSZGh

Working PC: http://ubuntuone.com/7WQPY1SS4Uymxbu3QjgHKf

The script came from this thread: http://ubuntuforums.org/showthread.php?t=2088102

And I've tried updating drivers etc as well as per the recommendations in that thread.

Finding it hard to understand why changing routers would cause this ?

The key difference is that the new router provides B/G/N mixed wireless mode and is also IPv6 capable.

Router logs are showing these entries regularly and seem to coincide with the connection failures:

wide-dhcp6c[9159]: dhcp6_ctl_authinit: failed to open /root/2012_FW/CID561NC/Formal_FW/
R0.09a0/rootfs/src/open_src/OWide//etc/dhcp6cctlkey: No such file or directory

Possibly an issue with IPv6 compatibility ?

I'm assuming DHCP6 is related to IPv6 ?

Finally, I'm using the Broadcom proprietary drivers:

" This package contains Broadcom 802.11 Linux STA wireless driver for use with 
Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, 
BCM43227- and BCM43228-based hardware."

Help would be enormously appreciated!

share|improve this question
    
MANY APOLOGIES!! Correction to my post - had the network logs the wrong way round... Should be: Not working HP Mini: ubuntuone.com/6zrjqJNi67uHfOyDUtSZGh Working PC: ubuntuone.com/7WQPY1SS4Uymxbu3QjgHKf Sorry for the confusion... –  Ian Fordyce Feb 27 '13 at 23:14
    
now corrected in the original post - didn't realise I could edit it... Yes, I'm a newbee. –  Ian Fordyce Feb 27 '13 at 23:24
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.