Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Actually trying to insatll MaaS server with ubuntu 12.04 and JuJu. Once installed, tried to add a new node in mass gui. It seems WoL worked and OS was installed, the new node had been deployed and running. However, when trying juju status after bootsrapping the environement, it seems something goes wrong with the DNS server.

$juju status
 INFO Connecting to environment...
ERROR Invalid host for SSH forwarding: ssh: Could not resolve hostname node01: Name or service not known

maas-dhcp is installed and configured in the MaaS server. No DNS service was added but use the default one (127.0.0.1 in /etc/resolv.conf file).

Chcek the /var/lib/misc/dnsmasq.leases.

No entries for the specified node!

Any idea?

share|improve this question
add comment

1 Answer

If you are using dnsmasq - you should have definied 'node01' inside the /etc/hosts. Is it there?

If not - try to add it:

192.168.1.25 node01

Replace ip with the correct one.

Check also:

ping node01
host node01
dig  node01

And check your files /etc/dnsmasq.conf, you can find some help here:

http://www.thekelleys.org.uk/dnsmasq/docs/dnsmasq.conf.example

share|improve this answer
    
thanks for the response but the problem I dont see any ip address assigned to the new node deployed ?? –  Aimar Feb 27 '13 at 11:14
    
What do you mean? What is ip of your node01? –  bluszcz Feb 27 '13 at 11:34
    
Node01 was deployed by maas [after adding it s maac address in maas UI]. node01 has been deployed and installed after running juju bootrap withinig the conf file. but i can't retrieve it s Ip address to add it in /etc/hosts in maas server. –  Aimar Feb 27 '13 at 11:38
    
What you should check - in /etc/hosts should be also your mac address for new host, like this: dhcp-host=4E:8C:B6:1B:AD:51,10.0.0.51 If its there - try to add manually, add some ip and restart dnsmasq –  bluszcz Feb 27 '13 at 12:08
    
I checked the /etc/hosts and still by default. No new node ip address or mac address are being added. Even try to add it manually I should add the associated ip address which is unknown ?? –  Aimar Feb 27 '13 at 12:13
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.