Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with texlive. For some reason I couldn't load the siunitx package anymore. Because I had problems with Texlive before, I accidently installed 2 versions next to each other with them having path dependencies. For some reason I can't recall I then decided just to delete texlive by just removing all the folders in which tex was present.

Now I tried to reinstall texlive, http://askubuntu.com/a/163683/27480. But during the install the following error occured:

[09:43|0] $ sudo apt-get install texlive-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  passivetex jadetex xmltex
The following NEW packages will be installed:
  texlive-full
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
22 not fully installed or removed.
Need to get 0 B/37.3 kB of archives.
After this operation, 106 kB of additional disk space will be used.
Selecting previously unselected package texlive-full.
(Reading database ... 630109 files and directories currently installed.)
Unpacking texlive-full (from .../texlive-full_2012.20120611-3~ubuntu12.04.1_all.deb) ...
Setting up tex-common (3.13~ubuntu12.04.1) ...
Directory /etc/texmf/ not writeable. Exiting.
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cm-super:
 cm-super depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing cm-super (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of context:
 context depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing context (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of context-modules:
 context-modules depends on context (>> 2011); however:
  Package context is not configured yet.
 context-modules depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing context-modules (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems pNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                     No apport report written because the error message indicates its a followup error from a previous failure.
                                                         No apport report written because MaxReports is reached already
                                                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                                                     No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 No apport report written because MaxReports is reached already
                                                                                                                               revent configuration of latex-cjk-chinese:
 latex-cjk-chinese depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing latex-cjk-chinese (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-japanese:
 latex-cjk-japanese depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing latex-cjk-japanese (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-korean:
 latex-cjk-korean depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing latex-cjk-korean (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-thai:
 latex-cjk-thai depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing latex-cjk-thai (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-all:
 latex-cjk-all depends on latex-cjk-chinese (>= 4.8.3+git20120621-1~ubuntu12.04.1); however:
  Package latex-cjk-chinese is not configured yet.
 latex-cjk-all depends on latex-cjk-japanese (>= 4.8.3+git20120621-1~ubuntu12.04.1); however:
  Package latex-cjk-japanese is not configured yet.
 latex-cjk-all depends on latex-cjk-korean (= 4.8.3+git20120621-1~ubuntu12.04.1); however:
  Package latex-cjk-korean is not configured yet.
 latex-cjk-all depends on latex-cjk-thai (= 4.8.3+git20120621-1~ubuntu12.04.1); however:
  Package latex-cjk-thai is not configured yet.
dpkg: error processing latex-cjk-all (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-fonts-thai-tlwg:
 latex-fonts-thai-tlwg depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing latex-fonts-thai-tlwg (--configure):
 dependency problems - leaving unconfigured
Setting up m-tx (0.60d-5~ubuntu12.04.1) ...
warning: kpathsea: configuration file texmf.cnf not found in these directories: /etc/texmf/web2c:/usr/share/texlive/texmf/web2c:/usr/share/texlive/texmf-dist/web2c:/usr/local/share/texmf/web2c.
/var/lib/dpkg/info/m-tx.postinst: 17: /var/lib/dpkg/info/m-tx.postinst: $TEXMFMAIN/web2c/mktexupd: not found
dpkg: error processing m-tx (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of musixtex:
 musixtex depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing musixtex (--configure):
 dependency problems - leaving unconfigured
Setting up pmx (2.6.18-2~ubuntu12.04.1) ...
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            warning: kpathsea: configuration file texmf.cnf not found in these directories: /etc/texmf/web2c:/usr/share/texlive/texmf/web2c:/usr/share/texlive/texmf-dist/web2c:/usr/local/share/texmf/web2c.
/var/lib/dpkg/info/pmx.postinst: 16: /var/lib/dpkg/info/pmx.postinst: $TEXMFMAIN/web2c/mktexupd: not found
dpkg: error processing pmx (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of texlive-formats-extra:
 texlive-formats-extra depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-formats-extra (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-lang-cjk:
 texlive-lang-cjk depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-lang-cjk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-lang-cyrillic:
 texlive-lang-cyrillic depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-lang-cyrillic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration ofNo apport report written because MaxReports is reached already
                                                                                                                No apport report written because MaxReports is reached already
                                                                                                                                                                              No apport report written because MaxReports is reached already
                                                      No apport report written because MaxReports is reached already
                                                                                                                    No apport report written because MaxReports is reached already
                                                                                                                                                                                  No apport report written because MaxReports is reached already
                                                          No apport report written because MaxReports is reached already
                                                                                                                        No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            No apport report written because MaxReports is reached already
     texlive-lang-czechslovak:
 texlive-lang-czechslovak depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-lang-czechslovak (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-lang-polish:
 texlive-lang-polish depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-lang-polish (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-xetex:
 texlive-xetex depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-xetex (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-math-extra:
 texlive-math-extra depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-math-extra (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-music:
 texlive-music depends on musixtex (>= 1:0.114-2); however:
  Package musixtex is not configured yet.
 texlive-music depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
 texlive-music depends on m-tx; however:
  Package m-tx is not configured yet.
 texlive-music depends on pmx; however:
  Package pmx is not configured yet.
dpkg: error processing texlive-music (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-omega:
 texlive-omega depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-omega (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-full:
 texlive-full depends on texlive-lang-czechslovak (>= 2012.20120516); however:
  Package texlive-lang-czechslovak is not configured yet.
 texlive-full depends on texlive-music (>= 2012.20120516); however:
  Package texlive-music is not configured yet.
 texlive-full depends on texlive-lang-cjk (>= 2012.20120516); however:
  Package texlive-lang-cjk is not configured yet.
 texlive-full depends on latex-cjk-all (>= 4.6.0+cvs20060714-2); however:
  Package latex-cjk-all is not configured yet.
 texlive-full depends on texlive-formats-extra (>= 2012.20120516); however:
  Package texlive-formats-extra is not configured yet.
 texlive-full depends on texlive-xetex (>= 2012.20120516); however:
  Package texlive-xetex is not configured yet.
 texlive-full depends on texlive-math-extra (>= 2012.20120516); however:
  Package texlive-math-extra is not configured yet.
 texlive-full depends on texlive-lang-polish (>= 2012.20120516); however:
  Package texlive-lang-polish is not configured yet.
 texlive-full depends on cm-super (>= 0.3.3-3); however:
  Package cm-super is not configured yet.
 texlive-full depends on texlive-omega (>= 2012.20120516); however:
  Package texlive-omega is not configured yet.
 texlive-full depends on texlive-lang-cyrillic (>= 2012.20120516); however:
  Package texlive-lang-cyrillic is not configured yet.
 texlive-full depends on context; however:
  Package context is not configured yet.
dpkg: error processing texlive-full (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 tex-common
 cm-super
 context
 context-modules
 latex-cjk-chinese
 latex-cjk-japanese
 latex-cjk-korean
 latex-cjk-thai
 latex-cjk-all
 latex-fonts-thai-tlwg
 m-tx
 musixtex
 pmx
 texlive-formats-extra
 texlive-lang-cjk
 texlive-lang-cyrillic
 texlive-lang-czechslovak
 texlive-lang-polish
 texlive-xetex
 texlive-math-extra
 texlive-music
 texlive-omega
 texlive-full
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You seem to have a writing permissions problem. See line 17 of your output:

Directory /etc/texmf/ not writeable. Exiting.

Hence, tex-common cannot be configured and since all other packages depend on tex-common, they cannot be installed either. Check your writing permissions on /etc/texmf.

I personally install texlive using this install script, without using the official repositories.

share|improve this answer
add comment

What I finally did listing all packages regarding tex, dpkg -l tex and purged them. Then a normal install worked again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.