Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem has been bothering me for 2 days and hope you guys can give me some advice.

I try to set up outlook.com as my mail service. And of course it require me to update my MX record to point to Microsoft's server.

And now, the problem is, no matter how I set the MX record, the value always end with my domain name. For example my domain is abc.com and I'm using BIND 9.7.3. Please refer the script below. But when I query using nslookup either using command line or online tool. I get the exchange value as a2d53f710931b4f6.pamx1.hotmail.com.abc.com. I tried the same thing on another server at a different datacenter and it turns out to be fine.

Do you guys have any idea what's wrong here? Is it my new server's BIND default setting problem or the network provider setting that effect it?

$ORIGIN abc.com.
@   IN  SOA ns1.abc.com. postmaster.abc.com. (
            2013022427
            8H
            2H
            7D
            1D )
                IN              NS              ns1.abc.com.
                IN              NS              ns2.abc.com.
                IN              MX              10 a2d53f710931b4f6.pamx1.hotmail.com
share|improve this question
    
yes, same thing happens here, but I just ignored it. –  Soroosh129 Feb 27 '13 at 8:55
add comment

1 Answer

Solved this problem by adding an dot (.) at the end of the MX record. Example:

a2d53f710931b4f6.pamx1.hotmail.com.

            IN              MX              10 a2d53f710931b4f6.pamx1.hotmail.com.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.