Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to turn off mouse acceleration to begin training my hand for better accuracy and precision in my mouse movements. How can I do this in Ubuntu 10.10?

share|improve this question
Personally I doubt that you will have better experience with acceleration completely turned off. You may need to tune it, but turning it off is gonna be really inconvenient. – ulidtko Feb 13 '11 at 20:27
@ulidtko: I game a bit from time-to-time (the extra accuracy really matters), and use Ubuntu for everything else. I want consistency in my mouse settings between my Windows and Ubuntu installs. – Matthew Pirocchi Feb 14 '11 at 2:38
Acceleration is extremely annoying. Even with the slider set to "low" it still annoying as hell, I can't understand why people use it. In windows you can at least just untick a box... – KarlP May 26 '12 at 13:31
up vote 3 down vote accepted

You can simply go to system/preferences/mouse to call up this preferences screen :

mouse preferences

Drag the highlighted option all the way to the left.

share|improve this answer
Owh. I wish all options of gpointing-device-settings were incorporated into gnome-mouse-properties. I really miss circular scrolling there. :/ – ulidtko Feb 13 '11 at 20:40
Yeah, it's a far better program and I think the idea for Natty might be to have it replace gnome-mouse-properties. Fingers crossed it makes the cut. One less thing for me to install after an install. – Scaine Feb 13 '11 at 20:58
I'm on 14.04 LTS and my mouse preferences screen looks completely different and lacks these options besides Primary Button, Double-click speed and simple linear pointer speed. – Dai Mar 28 at 20:31
@Dai, yeah, this answer is five years old now and sadly the gnome-simplicity march continues to make life hard for any kind of basic customisation. Incredibly, 5 years later, it's a total pain to turn off mouse acceleration, despite it causing all sorts of problems, particularly in games. Try this answer to see if it solves your issues:… – Scaine Apr 6 at 22:12

There is a GUI for this, gpointing-device-settingsInstall Gpointing device settings:

sudo apt-get install gpointing-device-settings 

GPointing Device settings dialog This program has several features missed in the standard gnome-mouse-properties configuration dialog, like advanced touchpad scrolling settings. If all you need is to adjust acceleration settings, use gnome-mouse-properties instead.

If you seek for CLI way, xinput will be to your usage.

share|improve this answer
On Ubuntu 16.04 getting Package gpointing-device-settings is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source – AlikElzin-kilaka Jul 21 at 14:55
Found a way to install it here: – AlikElzin-kilaka Jul 21 at 16:08

You can make it nice and simple simply by running:

xset m 00

Which will completely turn off mouse acceleration.

xset m 00

Save the file as a .sh script - make it executable with chmod +x filename, add it as a startup program in the Startup Applications program, and you're good to go!

share|improve this answer

I find the pointer acceleration extremely annoying. Even when it's set to "low"

Edited as the link is dead.

Find you input devices

xinput list

List current properties for the relevant id

xinput list-props <id>

Change the mouse pointer speed (non persistent)

xinput set-prop 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)' 'Device Accel Profile' -1
xinput set-prop 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)' 'Device Accel Constant Deceleration' 2

Setting Device Accel Constant Deceleration to 1.5 gives a slightly faster mouse.

To make the changes permanent, add the changes to a file and executed them automatically at login. Some options can be added to the x-server config.

More details here:

share|improve this answer
You saved my life, thanks – HappyDeveloper May 28 '12 at 5:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.