Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just downloaded the updates to Ubuntu 12.10; however, when I attempt to install these packages, I get this error [via Update Manager]:

installArchives() failed:
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
dpkg: error: parsing file '/var/lib/dpkg/available' near line 36442 package 'xserver-xorg-video-intel':
share|improve this question

1 Answer 1

Try: dpkg -configure -a

This command finish a disturbed update.

or

sudo dpkg --clear-avail - that will be my last guess

then

sudo apt-get update

share|improve this answer
    
Wait a minute... what was that second command again??? –  Eman Feb 26 '13 at 22:34
    
dpkg: error: parsing file '/var/lib/dpkg/available' near line 36442 package 'xserver-xorg-video-intel': Depends' field, reference to libdrm-intel1': version contains ` ' E: Sub-process /usr/bin/dpkg returned an error code (2) –  Eman Feb 26 '13 at 22:40
    
I tried, but it gave me an additional error message...sheesh! –  Eman Feb 26 '13 at 22:40
    
sudo apt-get clean - this command will clear all the downloaded packages. and then try update. –  Herby Pepper Feb 26 '13 at 22:50
    
Nope...it still didn't work. I'm still getting that same error message... –  Eman Feb 26 '13 at 22:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.