Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Catalyst version 11.1 with my AMD HD 6850 GPU. I've set up very basic and minimal X.Org config through gedit, because my card isn't fully supported by fglrx to auto-configure. As I predicted, the AMD Unsupported Hardware watermark came up. I used a special .sh script to remove it. However, I still can't resolve the video problem.

When I try to play videos via Totem, I get a black screen. While OpenGL works fine, YouTube videos and KMPlayer, Totem just can't render anything. I'm sure that has something to do with fglrx itself or with X.Org configuration. If you have any suggestions, I'd like to hear them.

Thanks in advance.

Linux ubuntu 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686 GNU/Linux

share|improve this question

closed as too localized by Bruno Pereira Feb 25 '12 at 1:28

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you add the content of your X.Org conf? –  RolandiXor Apr 15 '11 at 16:19
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 25 '12 at 1:28

1 Answer 1

I don't have any fglrx compatible card, but did you tried turning of xv video acceleration? (might be somewhere in Catalyst manager)

share|improve this answer
    
I tried adding these lines to my xorg.conf: ` Option "TexturedVideo" "on" Option "VideoOverlay" "off" Option "OpenGLOverlay" "off"` ...and it didn't work. I read phoronix.com/scan.php?page=news_item&px=ODcwMg here, that 6000 series doesn't support video acceleration, but I don't know how this is related to my problem. Thanks for the help, though. –  user10773 Feb 14 '11 at 13:20