Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When performing the sequence of commands:

sudo update-grub

Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.5.0-25-generic
Found kernel: /boot/vmlinuz-3.5.0-24-generic
Found kernel: /boot/vmlinuz-3.5.0-23-generic
Found kernel: /boot/vmlinuz-3.2.0-37-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

uname -r

3.5.0-23-generic

sudo apt-get -V install linux-generic linux-image-generic linux-headers-generic

Reading package lists... Done
Building dependency tree
Reading state information... Done 
linux-generic is already the newest version. 
linux-headers-generic is already the newest version.
linux-image-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I am learning about Linux refreshing up on my knowledge, and assistance would be greatly appreciated.

share|improve this question

3 Answers 3

I do not see anything wrong with any of those commands.

To use the most current kernel you need to reboot. The newest kernel will be the most recent and selected by default. You can select other, older kernels or other OS from the grub (boot) menu.

Ths last line, about one package not being upgraded, can almost certailny be fixed with:

sudo apt-get dist-upgrade
share|improve this answer
    
I tried that I get the same issue –  liamjeanius Feb 27 '13 at 1:04
    
When you boot, at the grub menu, select the new kernel. –  bodhi.zazen Feb 27 '13 at 1:41

I have a dual boot system with Ubuntu and Windows 7. I forgot that I installed Linux Mint Nadia 14 Meta into virtual box; because my external hard drive was producing an [errno 5]Input/Ouput error, that it was outdated or the read/write spend needed to be increased.I did not get around to troubleshooting that issue, so I install the virtual machine on my internal hard drive.
After trying your command it jogged my memory, sudo apt-get dist-upgrade, so I booted into Windows 7 and started virtualbox. When loading Linux Mint performing...
uname -r
3.5.0-25-generic
I remember cleaning the grub and removing 3.5.0-24-generic. I cleaned the grub.cfg and menu.lst in Ubuntu and rebooted. Plus booted back into Windows 7 and loaded Linux Mint to see if it would load, no issue so far.

Finally I booted back into Ubuntu and I haven't seen any issue so far. I would not know why the correlation between my virtualbox image and Ubuntu; especially, when in the advance options of the grub during boot it only shows the current kernels that are installed in Ubuntu....

Found kernel: /boot/vmlinuz-3.5.0-23-generic
Found kernel: /boot/vmlinuz-3.2.0-37-generic
Found kernel: /boot/memtest86+.bin

Thanks for you prompt to answers and I do appreciate the assistance.

share|improve this answer

Normally there is very good reason that grub is choosing an older version of the kernel to run on than a newer one. Either way, it is more than likely grub has selected an older kernel as the default. and you can change this by modifying /boot/grub/grub.cfg.

I'd first back this up with sudo cp /boot/grub/grub.cfg /boot/grub/grub.cfg.bak.

Find then the line the default line: sudo vim /boot/grub/grub.cfg +'/set\ default/'

Change the number value to which ever line the kernel is on that you wish to default boot from, starting from 0. You can also set this to be one of the options that's in the 'older versions' section by doing what number the submenu is, usually 2(third line) for most systems, and then >, and the 0 based line in that menu. so if I wanted to boot the first kernel in my old versions menu the line would be set default="2>0"

I hope this helps. Bare in mind though that this file will get overwritten every time update-grub is ran, so every kernel update will require this change.

share|improve this answer
2  
All files in /boot/grub mention that they are automatically generated and should not be edited! /boot/grub/* gets overwritten everytime update-grub is invoked (kernel updates). Use /etc/grub instead and then invoke update-grub manually for a proper fix. :) –  gertvdijk Jul 15 '13 at 16:07
    
@gertvdijk, in my system, the GRUB config lies in /etc/default/grub. Did I miss a symlink to it? –  Danatela Jul 15 '13 at 16:30
    
@Danatela Yeah, /etc/default/grub is the more end-user configuration, in /etc/grub.d/* (sorry wrong dir in previous comment) is the more advanced stuff that generates the /boot/grub/* stuff. –  gertvdijk Jul 15 '13 at 16:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.