Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run Kontact as another user using gksudo, gksu, or kdesudo, the theming is all messed up:

Kontact screenshot

When I run Thunderbird as another user, it works fine! I'm running Ubuntu 12.10 using the Unity interface.

How can I fix the theming of KDE apps when run as a different user?

share|improve this question

1 Answer 1

This looks like the 'Rodent' theme in gtk. Apparently qt apps under any different user can not automatically pick up the desktop theme.

Run:

xhost +
gksudo -u youruser qtconfig
xhost -
from the command line. If it is not installed, install it with sudo apt-get install qt4-qtconfig. Then set GUI Style to Gtk+ at the first, appearance tab. Save and exit. Subsequent 'sudoed' qt applications will pick up the running GTK theme.

However this might affect the looks of these apps when run under KDE. Perhaps file a bug report with the qt makers.

EDIT: Effective today, 2013-02-27, there is a qt-chooser-package in updates which might help these issues.

share|improve this answer
    
I'm not trying to run this as root, just as another regular user. When logged into that user, KDE apps look fine, it's just when I try to run them as that user but logged in as my regular user that they look bad. –  iBelieve Feb 26 '13 at 21:27
    
I tried running qtconfig and got this error: qtconfig: could not exec '/usr/lib/x86_64-linux-gnu/qt5/bin/qtconfig': No such file or directory. I think it is because I have the Ubuntu Touch SDK installed. When I tried to install qtconfig-qt4, apt-get says there is no such package. –  iBelieve Feb 26 '13 at 21:28
    
Also, I justed tried running a KDE app using as root and it didn't pick up the theme either. –  iBelieve Feb 26 '13 at 21:30
    
I have updated the answer to reflect this. Also fixed typo in package name. –  aquaherd Feb 26 '13 at 22:24
    
I still can't get qtconfig to run and I get same error message as before. Also, I don't see any package similar to the new one you named. –  iBelieve Feb 27 '13 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.