Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Explanation:

I have a VPS that comes with ubuntu 10.10. I'm using it for a webserver that runs a bunch of sites. My problem is that I cannot upgrade the distribution (which I really want) . I installed the needed software but at some point it start giving me problems. I think it is important to say that I changed to source.list from maverick to natty. So basicly I just copy the source list of natty and put it into the place of maverick.

THen I was able to install apache, php and etc.

Now when I try to install something it always gives me this error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 cpp-4.4 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 g++-4.5 : Depends: gcc-4.5 (= 4.5.2-8ubuntu4) but 4.5.3-12ubuntu2 is installed
 gcc-4.5 : Depends: gcc-4.5-base (= 4.5.3-12ubuntu2) but 4.5.2-8ubuntu4 is installed
           Depends: cpp-4.5 (= 4.5.3-12ubuntu2) but 4.5.2-8ubuntu4 is installed
           Depends: libgcc1 (>= 1:4.5.3-12ubuntu2) but 1:4.5.2-8ubuntu4 is installed
           Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libc6 : Depends: libc-bin (= 2.13-0ubuntu13.2) but 2.15-0ubuntu10.3 is installed
 libgomp1 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libmpfr4 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libnih-dbus1 : Depends: libnih1 (= 1.0.3-4ubuntu9.1) but 1.0.3-1ubuntu1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
root@348588:/var/cache/apt/archives# apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 cpp-4.4 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 g++-4.5 : Depends: gcc-4.5 (= 4.5.2-8ubuntu4) but 4.5.3-12ubuntu2 is installed
 gcc-4.5 : Depends: gcc-4.5-base (= 4.5.3-12ubuntu2) but 4.5.2-8ubuntu4 is installed
           Depends: cpp-4.5 (= 4.5.3-12ubuntu2) but 4.5.2-8ubuntu4 is installed
           Depends: libgcc1 (>= 1:4.5.3-12ubuntu2) but 1:4.5.2-8ubuntu4 is installed
           Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libc6 : Depends: libc-bin (= 2.13-0ubuntu13.2) but 2.15-0ubuntu10.3 is installed
 libgomp1 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libmpfr4 : Depends: libc6 (>= 2.14) but 2.13-0ubuntu13.2 is installed
 libnih-dbus1 : Depends: libnih1 (= 1.0.3-4ubuntu9.1) but 1.0.3-1ubuntu1 is installed
E: Unmet dependencies. Try using -f.

it is dependency problem. I read a bunch of articles from this website but none of them help me.

Does anyone have a solution for the problem? Thanks

share|improve this question

closed as too localized by AgentCool, Stephen Myall, vasa1, Jorge Castro, hhlp Feb 26 '13 at 15:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You might want to run 'apt-get -f install' to correct these. it says in the message ;) –  Rinzwind Feb 26 '13 at 9:30
    
However, this might help you: How do I resolve unmet dependencies?. –  Aditya Feb 26 '13 at 9:33
    
After changing the sources.list did you do: 'sudo apt-get update' and 'sudo apt-get dist-upgrade'? –  Javier Rivera Feb 26 '13 at 9:40
    
yes, I made both –  Pavel Genov Feb 26 '13 at 10:45
    
possible duplicate of How to install software or upgrade from old unsupported release? –  Jorge Castro Feb 26 '13 at 13:36

1 Answer 1

  1. Try as noted in the output apt-get install -f
  2. If this does not help, try to get back in a consistent state by removing the problematic packages for a while .
  3. Start with apt-get upgrade before you do a apt-get dist-upgrade. With a little bit luck you avoid some problematic dependency dead-locks this way.
  4. Try to update the libc6 package with apt-get install libc6 and look at the output to get a glue which packages are forcing the old version of the libc6 package.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.