Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use OpenShot for movie making. My ideal situation is to encode for the web HD, 30 Frames Per Second, to YouTube. This works out great as OpenShot has a setting for this. The problem is when i go to use it I get:

"The following formats/codecs are missing from your system:

libx264 libmp3lame

You will not be able to use the selected export profile. You will need to install the missing formats/codecs or choose a different export profile."

I have tried using Synaptic Package Manager and I think I am installing the right "plugins/codecs" yet to no avail or success. I used the instructions found here to remedy:

https://answers.launchpad.net/openshot/+faq/1040

I know this impacts OTHER video editing software (in other words it is not specific just to OpenShot). They give the same type of error message when i try to use their presets as well.

So in a word "Help!"... Any info is much appreciated!!!

PS - If you know of a BETTER way to do this (another software) that is appreciated too!
:-D

share|improve this question

4 Answers 4

Medibuntu (Multimedia, Entertainment & Distractions In Ubuntu) is a repository of packages that cannot be included into the Ubuntu distribution for legal reasons (copyright, license, patent, etc).

Some of these packages include the libdvdcss package from VideoLAN and the external binary codecs package (commonly known as w32codecs) used by MPlayer and xine.

follow this guide to include mediubuntu repository after that then :

sudo aptitude libavcodec-extra-52

Dependencies

* libavutil-extra-50 (>= 4:0.6)
* libavutil-extra-50 (<< 4:0.6-99)
* libc6 (>= 2.7)
* libdirac-encoder0
* libfaac0 (>= 1.26)
* libfaad2
* libgsm1 (>= 1.0.13)
* libmp3lame0
* libopencore-amrnb0
* libopencore-amrwb0
* libopenjpeg2
* libschroedinger-1.0-0 (>= 1.0.0)
* libspeex1 (>= 1.2~beta3-1)
* libtheora0 (>= 1.0)
* libva1
* libvorbis0a (>= 1.1.2)
* libvorbisenc2 (>= 1.1.2)
* libvpx0 (>= 0.9.0)
* libx264-98
* libxvidcore4 (>= 1.2.2)
* zlib1g (>= 1:1.1.4) 
share|improve this answer

Medibuntu is over... How to use OpenShot with Ubuntu 13.10 for Youtube videos?!

It doesn't work...

EDITED: Never mind, the package "libavformat-extra-53" is installed now, from Ubuntu 13.10 itself, codecs working!

Tks!

share|improve this answer
    
Indeed, Medibuntu is no longer maintained. The OpenShot developers also added some extra explanation, pointing the user to libavformat-extra as needed package. –  Treepata Dec 19 '13 at 10:38

What worked for me in 11.04 was the medibuntu package libavformat-extra-52, not libavcodec-extra-52.

sudo apt-get install libavformat-extra-52

After this, restart Openshot.

share|improve this answer

I had a problem with Openshot as well. I am using Linux Mint 16 Petra. I installed..

sudo apt-get install libavformat-extra-53

and it worked fine when I opened back up and exported MPEG-4 video.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.