Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

enter image description here

I want to know the solution to this and resume my downloading. I am running Ubuntu 10.10.

share|improve this question
you may use gimp to "gully" unwanted text away :) – antivirtel Feb 13 '11 at 17:08
@BRoland: There. Fixed. – Nathan Osman Feb 13 '11 at 20:22
Ok George, thanks :) – antivirtel Feb 13 '11 at 22:10
Didnt know about that. My bad! – TheMaimoon Feb 14 '11 at 12:20
up vote 3 down vote accepted

In my system: drwxr-xr-x 6 root root 4096 2011-02-13 13:36 media/ it is writeable only by root. The system stores here the mounted volumes, like: USB flash drive, Cardreader, mounted HDDs... etc...

If you are looking for a place, where you want to store your personal data, in only your home dir, like: /home/YourName or the siple ~ refers to it.

Ubuntu makes you some default dirs, like: Music, Video... in your home dir. I suggest you, to place your movies there, to Videos; or you can individualy make a dir in your home folder. This is situated on GNOME menu > Places > Home folder (the first)

Illustration(from google): home dir ubuntu 10.10

share|improve this answer
/media is usually a space where other filesystems are mounted, but a directory is created in that, and that directory's ownership is set, etc etc. So it's useless to check the permissions of /media, because especially removable medias are automounted in a directory created in /media with proper permissions. – LGB Feb 13 '11 at 13:46
The system stores here the mounted volumes, like: USB flash drive, Cardreader, mounted HDDs... etc... I wrote that, "etc" means the others, what hasn't listed. I checked the permissons only to make my suggestions understood. – antivirtel Feb 13 '11 at 13:50
Roland: I see, and you'right, but I haven't understood why you mentioned the permission of /media itself, it's totally unimportant since it's not a habit to have one filesystem mounted right in /media, but one directory deeper only. Also from the screenshot (what the question has) I have the idea that some media is mounted there which has the name "The.Green.Hornet....", that's why I've suggested in my answer to check out what it is. – LGB Feb 13 '11 at 14:25
Thanks will change all download locations to a dir in home folder! – TheMaimoon Feb 14 '11 at 12:22

It seems transmission can't open the target file, maybe you don't have the proper rights for that. What's mounted in that directory /media/The.Green. ... ? Use terminal, this command: df -aT /media/... where the path at the end is the same as your screenshot shows.

Why do you want to download there? Do you have some pendrive, whatever which is autmounted and you want to download onto it? I am just wondering why don't you download into your home directory, have you got any special reason?

share|improve this answer
I am downloading it in a external HDD. Its a 1TB WD MyBook. I have everything saved on that drives. My folders, documents, music, videos. Everything. – TheMaimoon Feb 14 '11 at 12:23

You should not store user files in the /media folder, it contains mount points for removable media like CD's or USB memory sticks. This folder is owned by the root user who has permission to write to this directory (owner=root, group=root, mode=0755).

Each user has a Home folder, located at /home/you-username. In that directory, you can store your personal files and settings. Ubuntu creates additional directories in that folder like Videos, in which you can put your downloaded videos.

Please read the manual page about the Filesystem hierarchy to get a better understanding of folders like /media.

share|improve this answer

Transmission does not run under the logged-in username, instead it uses the username 'debian-transmission'. Consequently, downloading to a home folder won't work, because 'debian-transmission' does not have write permissions to any of the user's home folders. The default download location is in the /var directory, because 'debian-transmission' (and I believe most local users?) have write access to that directory tree.

mikewhatever answers the question of how to download directly into one of the /home folders, in this other askubuntu: Permission denied when downloading with transmission deamon

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.