Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently updated to KDE 4.10. Now when I minimize windows, the task manager shows them being black and white. I find this very annoying since I tend to find windows primarily based on colors, not based on the shape of their icon. It takes me usually at least twice as long to find the window I'm looking for now because of this. Is there any way to switch it back to previous behavior where minimized windows would still have color in the task manager?

This is what it looks like now. Firefox is minimized while the System settings window is not. It's usually quite easy to spot a bright orange and blue icon. Not so here:

KDE 4.10 task manager ugliness

share|improve this question
up vote 8 down vote accepted

The solution was to go to:

System Settings > Application Appearance > Icons > Advanced

And under All Icons remove the effect for the Disabled icon.


Here's the respective KDE bug report

share|improve this answer
Thanks a pile, that was one thing driving me nuts after switching to Debian Jessie with KDE Plasma! – sumitkm Oct 31 '15 at 10:53


The default KDE task manager has filter setting - with the "Only show tasks that are minimized" the KDE 4.10 task manager will show the icons with the colors.

enter image description here

There are other task managers

Earlier: Modify KDE Desktop theme

The other task managers don't paint the minimized application icons grey.

enter image description here

Or use the default task manager filters

enter image description here

share|improve this answer
Thank you for your answer, however I do not want to use the Icon Only or Smooth task managers and it would aggravate me beyond belief to have the task manager only show minimized windows. I have posted my own answer below which actually "solves" the problem. – Mike Feb 28 '13 at 22:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.