Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Samsung Ultrabook NP530 (i5, 8 GB, 16 GB internal SSD + 500 GB HD, HD4000 + Radeon 7500) has an internal 16 GB SSD which windows drivers use for caching and suspend/resume. I have no use for Windows, so I wanted to wipe the disk, install Ubuntu on the SSD and use the 500 GB HD as my /var and /home partition.

This works, I can install Ubuntu 12.10 and 13.04 on the SSD which is /dev/sdb (grub loader goes onto /dev/sda). The problem is, the performance is horrific:

/dev/sda:
Timing buffered disk reads: 260 MB in 3.00 seconds = 86.58 MB/sec
/dev/sdb:
Timing buffered disk reads: 24 MB in 3.13 seconds = 7.67 MB/sec

Ubuntu boots in like 2 mins, Firefox takes 15+ secs to launch. I've tried encrypted LVM, ext2 and ext4, with the automated install, no changes. Funny thing is, if I create the partition before the install with gparted, I get normal results:

/dev/sdb:
Timing buffered disk reads: 388 MB in 3.10 seconds = 125.11 MB/sec 

Then I ran hdparm immediately after the install was finished, before rebooting, and it's back to crappy:

/dev/sdb:
Timing buffered disk reads: 20 MB in 3.24 seconds = 6.16 MB/sec

I've exchanged the 500 GB HD with a 120 GB SSD and the install was a breeze, 4 secs from crypt passkey to desktop.

EDIT: the install process has nothing to do with the problem. I create a partition with Gparted, run hdparm on the empty partition and get 150-200 MB/sec. As soon as I write one file to the disk and run hdparm again, it regresses to 6 MB/sec.

What am I missing here?

EDIT II: after countless tries and retries, I've come to a point when it works (yay!) for an undetermined amount of time and then it goes back to being useless. for example, today I tried it like ten times, every time there was this 2+ mins boot, 6 MB/s read speed etc. then I booted off a LiveUSB. tried hdparm -t /dev/sdb1 and my speed was back to 200+ MB/s. reboot, and now I'm typing this from a blazing fast laptop.

I am out of ideas.

EDIT III: removing the hard disk (500 GB) for a couple of seconds and the plugging it back in fixes things! Speeds are north of 200 MB.

share|improve this question
    
Maybe an issue with the SSD firmware?. –  Uri Herrera Feb 25 '13 at 20:45
    
it's a sandisk i100 ssd, intended for embedded systems, tablets and the like... couldn't find any info on firmware upgrades. this guy says he pulled it off and he got his 3 sec boot time. –  sostacked Feb 25 '13 at 22:37
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.