Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am using ubuntu 12.04 (switched from windows 8 recently) and I am finding that this OS is draining my laptops battery like anything (works only like 70% of windows). I also found this interesting quote from wikipedia:

Ubuntu 10.04 LTS has also been criticized for its poor battery life on Laptops and Netbooks, even as OEM on devices such as Asus's eeePC, when compared to Microsoft Windows 7, with Ubuntu having been shown to use between 14–56% more power.[122] Ubuntu's developers have acknowledged and sought to solve the issues of power consumption in the 12.04 LTS release.

Can ubuntu experts suggest me some tips and tricks to save my battery life ?

Also tell me how can I monitor my battery usage, like which application/process is more resource(power) consumptive ? Is there any way we can select system performance schemes like we do in Windows like High Performance or Battery Saver types ?

I also see a problem with my ubuntu display brightness setting. I manually set it to lowest possible but ubuntu forgets my setting everytime I reboot my machine. Is there any way we can permanently save this setting and ubuntu can remember it ?

share|improve this question

marked as duplicate by Rinzwind, Geppettvs D'Constanzo, Stephen Myall, fossfreedom Feb 25 '13 at 20:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
This has been asked several times on AU... askubuntu.com/questions/9817/… and askubuntu.com/questions/400/… –  Rinzwind Feb 25 '13 at 19:13
    
Now a days most laptops comes with dual grpahics/ hybrid gpu/ optimus configuration. If you don't install correct drivers, correct work around both GPU will be on and will drain battery –  Web-E Feb 25 '13 at 19:21
    
Brightness issue may be fixed by installing correct drivers. to get more help, post result of lspci | grep VGA –  Web-E Feb 25 '13 at 19:22
    
@Web-E : avimehenwal@AviMehenwal-DYNAC:~$ lspci | grep VGA 02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4300 Series] –  Avi Mehenwal Feb 25 '13 at 19:27
    
@Web-E Just checked from 'Additional Drivers' that I am using "ATI/AMD proprietary FGLRX Graphics driver" on my laptop. Does this driver also creates concern ? –  Avi Mehenwal Feb 25 '13 at 20:01

1 Answer 1

Well for the brightness you should look here. You can't make Ubuntu remember your brightness settings but it will always boot with a predefined brightness level.

For the battery life you have to activate laptop-mode. It might not be active by default. To check on that here is a link to a complete walk through.

For the high performance and such power schema you can download Jupiter. You can copy and paste the following commands in a command line:

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

EDIT: Also Web-E has a great point, you should check if you have two graphic cards (i.e. nVidia Optimus technology - most modern laptops have this technology). If you do, you can install Bumblebee and then you can run every graphic intensive application using the command optirun before it.

share|improve this answer
    
Thank you very much for your very informative answer :) But I dont have nVidia ! my laptop has ATI Graphic Card –  Avi Mehenwal Feb 25 '13 at 19:46
    
and @Soroosh129 I cannot even edit file /etc/rc.local for brightness issue. It says "chmod: changing permissions of `rc.local': Operation not permitted" when I try to change the file permissions for editing. –  Avi Mehenwal Feb 25 '13 at 19:56
    
I don't see any reason to use chmod. –  Soroosh129 Feb 25 '13 at 20:01
    
avimehenwal@AviMehenwal-DYNAC:/etc$ ls -l | grep rc.local -rwxr-xr-x 1 root root 306 Aug 18 2012 rc.local –  Avi Mehenwal Feb 25 '13 at 20:06
    
you have the write permission as a root. try sudo vi /etc/rc.local and see how that goes. edit: sorry I keep forgetting that your user is root, my bad but doesn't make any difference. –  Soroosh129 Feb 25 '13 at 20:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.