Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to install Spotify, but when logging in I get a message saying I have an error 101. This appears to be related to either my proxy settings or to my firewall. Following instructions from another similar question I've entered the following into a terminal iptables -L and it has returned this message which sounds a bit worrying!

FATAL: Error inserting ip_tables (/lib/modules/3.5.0-25-generic/kernel/net/ipv4/netfilter/ip_tables.ko): Operation not permitted
iptables v1.4.12: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

Any idea's what the solution is to both my apparent lack of firewall and to solving my ability to get into Spotify?

share|improve this question
    
first , can you provide the output of modprobe ip_tables ? this will tell us what kernel you are using - also , was this ran as root ? –  linux_guy Feb 25 '13 at 19:30
    
Don't panic. It is just an error message your computer is not going to die. Can you please describe the spotify issue a bit more? –  Magpie Feb 25 '13 at 19:33
1  
I try to log into Spotify and it says "An error occurred A firewall may be blocking Spotify. Please update your firewall to allow Spotify (error 101). Additionally you could try to update your currently used Proxy settings." "Proxy settings" is a link to a new box with the first box automatically set to autodetect, 2nd box says "Host:" but is grayed out unless i alter 1st box and similarly boxes 3,4, and 5, "port", "username" and "password" respectively can't be changed unless I change 1st box to saying "HTTPS", "Socks 4" or "Socks 5". The first box also has option to say "No Proxy". –  Chris Feb 25 '13 at 21:38
    
Sorry linux guy, I don't understand your question. I've only been using Ubuntu for a couple of days! I only typed "iptables -L" into the terminal thingy as an answer to a similar problem suggested it and it helped that person resolve their problem but the read out totally confused me! –  Chris Feb 25 '13 at 21:42

3 Answers 3

I think you needed to use the sudo command and the error message is just a badly worded way of telling you that you don't have the correct permission to run the command you wanted to run.

Here is a link to some instructions on how to get a firewall going with iptables.

share|improve this answer

The iptables command administers your 'firewall' (or in technical terms: packet filter). It needs more permissions than a normal user has. So entering the command as a normal user leads to the error message you posted. If you prepend sudo and enter your password at the following prompt you'll get root permission for this single command. So sudo iptables -L writes output without error message:

> sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

However I doubt that this will help to find a solution for your spotify problem. It might be better to ask another question and insert the full error message in that question. Maybe we can help you better there.

share|improve this answer

I know this is an old thread, but maybe this will help someone. The error message reflects that there are missing kernel files. You can rectify this on any version of Ubuntu with the following command:

    sudo apt-get install linux-image-$(uname -r)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.