Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanna use I3 as WM with a gnome-panel on the bottom. But when i try to start the gnome-panel, I3 crashes. So how is it possible to run both?

Another question is: How can i connect to the internet (over wifi and cable) when I3 starts? In standard i get no connection after starting (and waiting some time). Do i need a static configuration or is there a better/other possibility?

Best Regards

share|improve this question
add comment

2 Answers 2

Install wicd-gtk

then, add the following autorun in your .i3/config :

exec wicd-gtk -t

this should give you auto-internet connectivity. You can choose the network to auto-connect in the wicdt-gtk gui.

share|improve this answer
1  
In my .i3/config I add : exec --no-startup-id wicd-gtk -t to disable the mouse hourglass on i3 startup. –  ChoiZ Mar 20 at 22:02
add comment

In the version of i3 that came with Ubuntu 10.10, there was a bug that caused it to crash when running with Gnome. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610143 . However, in the version of i3 that comes with Ubuntu 11.04, the bug is fixed.

The way I got i3 to run as the WM for gnome (i.e. i3 + gnome-panel) was to go run gconf-editor, navigate to /desktop/gnome/session/required_components, and add/edit the key called windowmanager to have the value i3 (it was previously metacity or compiz). Next time you run Gnome (now "Ubuntu Classic") from GDM, it will use i3 as the window manager. For some reason, though, it takes like 30 seconds to start up the panel, so be patient.

Update 2012-05-10

When I upgraded to Ubuntu 11.10 and 12.04 I had to use a different solution (which works for both). I created a file called /usr/share/gnome-session/sessions/gnome-i3.session with the followingcontents:

[GNOME Session]
Name=gnome-i3
RequiredComponents=gnome-panel;gnome-settings-daemon;
RequiredProviders=windowmanager;
DefaultProvider-windowmanager=i3
DefaultProvider-notifications=notify-osd
IsRunnableHelper=/usr/lib/gnome-session/gnome-session-check-accelerated
FallbackSession=gnome-fallback
DesktopName=GNOME

Then at the lightdm login screen, I just select gnome-i3 instead of "Ubuntu 2D" or whatever else is in the list. I may have had to install gnome classic/fallback as well, but there should be plenty of tutorials online on how to get that installed if it's not there already.

Another thing to note: when I upgraded i3 to 4.2 (I use the i3 Ubuntu repository), whenever I logged in the gnome-panel wouldn't appear until after I launched my first application.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.