Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've always bound the F{1..4} keys to quickly switch between workspaces.

Now the F1 shortcut is stuck to the help popup ("user & system settings"). I've tried different options, the best I could get was to stop the help window to popup by binding the F1 key to workspace1 using dconf or GConf, but it still doesn't switch to workspace1.

This setup has worked for years, even with the previous versions of GNOME Shell on Debian testing. I've switched only recently to Ubuntu and both versions 12.04 and 12.10 have this issue on different computers.

share|improve this question

1 Answer 1

If you are using Compiz, this answer provides a good way to do the trick by using it in combination with the "Commands" plugin inside of Compiz.

What I did is to set the proper command line in the desired position, as shown in the next screenshot:

enter image description here

The commands starts in the "Command line 3"

Then we can setup the proper key binding for each command in the "Key Bindings" tab as shown in the next screenshot:

enter image description here

The proper key bindings also starts in the "Run Command 3"

It is working, and must work on every Compiz based/capable desktop environment. I am using XFCE for this example and this trick is doing a great work. And this also works in Unity. I hope this help you.

Good luck!

share|improve this answer
    
Thanks for the tweak, it works great ! There's even an option to switch to the given workspace using: wmctrl -s <num>. I finally get the shortcut to work as expected as well after upgrading from 12.04 to 12.10 using this: update-manager. It took days (literally) but did the job rightly. So I guess my problem was in my configuration files from an older version of Gnome-Shell which are no longer fully compatible. So for people having this issue, the problem might not occurs with a freshly created user, easy to test. –  annoyed Feb 26 '13 at 13:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.