Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently moved /boot to a different partition (first partition on my disk, sda1), no problems booting or anything.

But now I noticed gnome-system-monitor only shows one CPU bar. It used to show two (CPU1 and CPU2).

When I run $ cat /proc/cpuinfo | grep processor | wc -l it returns 1. When I run $ uname -r it returns 3.2.0-38-generic. It didn't do this before I moved /boot.

A little bit of Googling says I need to install generic-pae kernels to be able to use both cores. But when I do $ sudo apt-get install linux-generic-pae linux-headers-generic-pae I get a dependency error:

The following packages have unmet dependencies:
 linux-headers-generic-pae:i386 : Depends: linux-headers-3.2.0-38-generic-pae:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What is going on? What can I do to fix this? Is that info accurate? Is my laptop actually only running on only 1 core?

Edit1: My system is a Lenovo x131e-3372-2vu, AMD E2-1800 APU.

Edit2: Looking at syslog right after boot, dmesg logs that my second core, CPU1, is unresponsive when it tries to bring it online: CPU1: Not responding. It's worth noting that both cores work fine on Windows 8.

Edit3: Okay, so I don't think the issue is with having a generic or generic-pae kernel or not, since generic-pae is only needed to activate more than one core if you have a 32-bit installation. Mine is definitely 64-bit `

share|improve this question
    
What error did it say when you try to install linux-headers-3.2.0-38-generic-pae ? –  NotFromBrooklyn Feb 25 '13 at 7:53
    
This is the error: The following packages have unmet dependencies: linux-headers-3.2.0-38-generic-pae:i386 : Depends: linux-headers-3.2.0-38:i386 but it is not installable E: Unable to correct problems, you have held broken packages. –  oaskamay Feb 25 '13 at 7:58
    
I'm running on 3.2.0-37-generic, and I get multiple cores: your cpuinfo command returns 3 for me. So maybe you have a different problem? What does dmesg print? I have a line in its output that says Brought up 4 CPUs. My laptop's running on an Intel processor, though. –  daniel kullmann Feb 25 '13 at 8:01
    
OK, where are the kernel headers saved? I think it may be in the boot folder. If so, check if the /boot partition is writable. –  NotFromBrooklyn Feb 25 '13 at 10:15
    
Alright, so I don't think the issue is with the kernel. Updated the post to reflect that. Also, syslog shows that it was unable to bring up CPU1: CPU1: Not responding shows up in the log at boot. Good news is, the issue is gone! I read somewhere that someone solved this issue by disconnecting a USB hub. I disconnected my laptop cooler (USB to laptop) and wireless mouse adapter, and it booted with 2 cores online. Not sure what exactly caused the problem though. All I know it's not OS-related or hardware-related. Thanks for all the help :) –  oaskamay Feb 25 '13 at 16:13
show 1 more comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.