Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

2 hours ago I installed Ubuntu while listening to music on my headphones (wubi install). I then also played music on Ubuntu just fine, yet when I rebooted into Windows, without doing anything else besides opening Chrome, my headphones stopped working.

Exact same problem as in this thread: headphones not working on Windows after installing Kubuntu 12.10, which was left with many doubts and no answer.

Luckily I have not done anything on windows after installing Ubuntu 12.10, nor have I mingled with the audio driver. I fixed the problem using some advice from a discussion thread by rebooting into Linux and forcing the laptop to shutdown by holding the power button (in order to prevent Linux from muting the headphone jack in a way that Windows doesn't see). The headphones now work like before, thus it is obviously a problem originating from Linux.

Although this trick works for now, and I assume that it will work as long as I never shutdown Linux properly, I would definitely like a proper solution to this.

The discussion thread where I was told to crash Linux: https://bbs.archlinux.org/viewtopic.php?id=146773

share|improve this question
1  
I didn't get what caused you to force shut down using the power button. If the computer had frozen, did you try any of these: askubuntu.com/questions/4408/… except the last one of course. –  i08in Feb 25 '13 at 1:10
    
Linux didn't freeze, I forced the shutdown so that it doesn't set any flags to mute the headphones. (also no, sound was not simply muted in windows) –  csiz Feb 25 '13 at 3:01

4 Answers 4

Have you tried this?

echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf  

Source: http://ubuntuforums.org/showthread.php?t=2022151

share|improve this answer

I have had this problem too, but I have found a way around that.

What I do is when I'm done using Ubuntu, before restarting to go to Windows, I mute the speakers, plug in headphones and mute that too, before going to Windows. When I don't mute sound in Ubuntu, the laptop speakers work in Windows, but no audio comes from headphones.

This answer may not apply to you if this temporary solution does not work.

Hope this helps.

share|improve this answer

I have had a similar issue, if I am getting you right. To me it also happened after installing and using Ubuntu 12.04 for some time. Sound worked with laptop speakers, but not with headphones. I have tried several fixes that I don't remember now, but what helped was reinstalling drivers in Windows (8). As simple may this sound, this was the easiest fix and it worked in my case. Hope it helps. Good luck!

share|improve this answer

I have had this problem also. You just have to shutdown from Ubuntu not restart. Once the computer is off start it and choose windows, everything should work just fine.

share|improve this answer
    
Powering off (cold booting) the system will probably cause all registers to be reset, while a warm reboot will not. This is actually an issue with your BIOS or the Windows drivers - it should reinitialize all registers properly. –  gertvdijk Jun 20 '13 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.