Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've ALready installed Steam But when i click on the program i get this message

ERROR- You are missing the following 32-bit libraries, and Steam may not run:
not

I dont know what to install or EVEN DO I've tried to look answers up but i got NOTHING...

share|improve this question
2  
We need the complete error message. –  Javier Rivera Feb 24 '13 at 20:38
3  
That is the Complete message it doesnt go on after not –  Unb3liveblE - PoW Feb 24 '13 at 20:46

6 Answers 6

up vote 3 down vote accepted

No problem. Welcome to Linux and Ubuntu, by the way.

First, if you didn't install Steam from the Ubuntu Software Center, and didn't try, see if you can install it that way, removing Steam from your system beforehand. You may need to run sudo apt-get update in a terminal beforehand (when it prompts you for your password, it's typing even if nothing shows up onscreen). I've also noticed that Steam only shows up in the Software Center when you click "show technical items" at the bottom.

If that doesn't help, see https://developer.valvesoftware.com/wiki/SteamCMD#32-bit_libraries_on_64-bit_Linux_systems. Follow the instructions for Debian-based distributions. Let me know if these instructions don't make sense.

share|improve this answer

I had a similar problem with nVidia and Steam, using a GeForce 650ti with the 331 drivers. I ended up CTRL-ALT-F1, logging in, sudo service lightdm stop, telinit 3 (perhaps not needed after the service stop), and sudo sh NVIDIA*.run. The original 331 drivers were removed, and the installation (this time) went fine, and Steam works.

share|improve this answer

This seem to happen on every 64 bits OS.

Full bug report here: https://github.com/ValveSoftware/steam-for-linux/issues/321

Solution:

gksudo gedit /etc/ld.so.conf.d/steam.conf

Add next two lines to file:

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

Then execute:

sudo ldconfig

Now you should be able to run Steam


solution found here: http://steamcommunity.com/app/221410/discussions/0/864959336441792994/?l=russian

share|improve this answer
1  
This was my solution in ubuntu 13.10. I don't remember having this problem in ubuntu 12.04. –  isaaclw Dec 26 '13 at 18:32
1  
This is the cleanest way to resolve the problem in 13.10. A user shouldn't be creating symbolic links in /usr/lib, as per the current highest voted answer. –  XBigTK13X Apr 15 at 14:29

How to run Steam with ATI 13.04 on Ubuntu 13.04 64bit with kernel 3.8.12:

  1. open terminal

  2. Create startup file in your home directory:

    sudo gedit st3am.sh
    
  3. put this in file:

    LD_PRELOAD=/usr/lib32/fglrx/libGL.so.1 steam
    
  4. Save & make executable:

    chmod a+x st3am.sh
    
  5. Make shortcut and move to desktop or add to your application menu

  6. Have a fun :)

share|improve this answer

You are propably running an 64bit version of Ubuntu.

Just open the terminal and type:

sudo apt-get install ia32-libs

This way you'll have full compatibility with 32bit applcations, such as Steam, skype and others.

share|improve this answer
    
This package isn't available for debian wheezy, or for suacy (13.10). I'm trying to remember when the migration happened for ubuntu... but they migrated from installing 32 bit packages this way. –  isaaclw Dec 26 '13 at 18:21

Here's what I had to do on Intel Sandy Bridge (HD3000 graphics)- for Nvidia/AMD use appropriate source:

sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib

Steam and 3D in vmWare works now.

share|improve this answer
    
This actually fixed my problem, thanks! –  Michael Aquilina Oct 9 '13 at 21:45
    
This worked for me (AMD here). What I had to do was install the multiarch 32-bit fglrx package which provides libGL.so, which was named libgl1-fglrx-glx:i386, and then create the symlink to /usr/lib/i386-linux-gnu/fglrx/libGL.so.1. Then it worked perfectly. –  Thomas Dec 31 '13 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.