Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't have Virtualbox and I'm not really good with codes and stuff, but I updated my machine from 12.04 to 12.10 and now the internet is not working. The only message I got was 'nautilus has not started' when I open chrome:

Error 105 (net::ERR_NAME_NOT_RESOLVED): unable to resolve the server's DNS address.

I tried sudo apt-get install dnsmasq but it came back with the following:

E:unable to locate package dnsmasg.

Then

Reading package list... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcd4 libequinox-osgi-java libgraph4 libgvc5 libpathplan4
  libservlet3.0-java
use 'apt-get autoremove' to remove them.
The following NEW package will be installed
  dnsmasq
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.1Kb of archives
After this operation, 115 kB of additional disk space will be used.
Warning: the following packages cannot be authenticated!
  dnsmasq
Install these packages without verification [y/N]? y
Err http://gb.archive.ubuntu.com/ubuntu/ quantal/universe dnsmasq all 2.63-1ubuntu1
  Something wicked happened resolving 'gb.archive.ubuntu.com:http' (-5 - No address associated with hostname)
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/universe/d/dnsmasq/dnsm
asq_2.63-1ubuntu1_all.deb Something wicked happened resolving 'gb.archive.ubuntu.com:http' (-5 - No address associated with hostname)
E:unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

******@desktop:~$ apt-get autoremove
E:could not open lock file /var/lib/dpkg/lock 0 open (13: Permission denied)
E:unable to lock the administration directory (/var/lib/dpkg/), are you root?

I've also deleted the wired connection then added it back to all default settings, but am still having no joy whatsoever.

I am on a wired connection.

I have rebooted computer and modem.

I have also tried google DNS 8.8.8.8 8.8.4.4

Please help :)

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.