Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've removed totem and installed VLC instead. Now video files thumbnails are gone. Is there any way to get thumbnails back without reinstalling totem?

I know I can have both totem and VLC, but I really don't want to have more soft than I need :)

share|improve this question
add comment

2 Answers

I had no keys under desktop/gnome/tumbnailers in gconf-editor on 11.10 and 12.04. All thumbnails were generated normally, except for movies, because i uninstalled totem.

To use ffmpegthumbnailer i installed it like in upper post:

sudo apt-get install ffmpeg ffmpegthumbnailer gstreamer0.10-ffmpeg

Then deleted thumbnail cache like in upper post:

rm ~/.thumbnails/fail/gnome-thumbnail-factory/*
rm ~/.thumbnails/normal/*

I then made a change in /usr/share/thumbnailers/totem.thumbnailer

from this:

[Thumbnailer Entry]
TryExec=/usr/bin/totem-video-thumbnailer
Exec=/usr/bin/totem-video-thumbnailer -s %s %u %o

to this:

[Thumbnailer Entry]
TryExec=ffmpegthumbnailer
Exec=ffmpegthumbnailer -s %s -i %i -o %o -c png -f -t 10

And exited nautilus:

nautilus -q

It is all working great now. Hope it helps!

If thumbnails still fail to generate, you might need to add the following to /usr/share/thumbnailers/totem.thumbnailer:

MimeType=application/mxf;application/ogg;application/ram;application/sdp;application/vnd.ms-wpl;application/vnd.rn-realmedia;application/x-extension-m4a;application/x-extension-mp4;application/x-flash-video;application/x-matroska;application/x-netshow-channel;application/x-ogg;application/x-quicktimeplayer;application/x-shorten;image/vnd.rn-realpix;image/x-pict;misc/ultravox;text/x-google-video-pointer;video/3gpp;video/dv;video/fli;video/flv;video/mp2t;video/mp4;video/mp4v-es;video/mpeg;video/msvideo;video/ogg;video/quicktime;video/vivo;video/vnd.divx;video/vnd.rn-realvideo;video/vnd.vivo;video/webm;video/x-anim;video/x-avi;video/x-flc;video/x-fli;video/x-flic;video/x-flv;video/x-m4v;video/x-matroska;video/x-mpeg;video/x-ms-asf;video/x-ms-asx;video/x-msvideo;video/x-ms-wm;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvx;video/x-nsv;video/x-ogm+ogg;video/x-theora+ogg;video/x-totem-stream;audio/x-pn-realaudio;audio/3gpp;audio/ac3;audio/AMR;audio/AMR-WB;audio/basic;audio/midi;audio/mp2;audio/mp4;audio/mpeg;audio/ogg;audio/prs.sid;audio/vnd.rn-realaudio;audio/x-aiff;audio/x-ape;audio/x-flac;audio/x-gsm;audio/x-it;audio/x-m4a;audio/x-matroska;audio/x-mod;audio/x-mp3;audio/x-mpeg;audio/x-ms-asf;audio/x-ms-asx;audio/x-ms-wax;audio/x-ms-wma;audio/x-musepack;audio/x-pn-aiff;audio/x-pn-au;audio/x-pn-wav;audio/x-pn-windows-acm;audio/x-realaudio;audio/x-real-audio;audio/x-sbc;audio/x-speex;audio/x-tta;audio/x-wav;audio/x-wavpack;audio/x-vorbis;audio/x-vorbis+ogg;audio/x-xm;application/x-flac;

And again run nautilus -q in terminal.

share|improve this answer
    
This wonder why this is not accepted as an answer. –  Chirag Aug 18 '12 at 23:52
add comment

Open file manager and go to Edit -> Preferences -> Preview. Change preferences as required. Then close file manager and open terminal. Run the following command to install the necessary packages.

sudo apt-get install ffmpeg ffmpegthumbnailer gstreamer0.10-ffmpeg

Then remove the old thumbnails

rm ~/.thumbnails/fail/gnome-thumbnail-factory/*
rm ~/.thumbnails/normal/*

Open the file manager and enjoy your new thumbnails!

share|improve this answer
    
When I tried this the video files (.avi for example) don't have thumbnails anymore) –  koushik Oct 1 '10 at 21:38
    
You have to change also thumbnailers with gconf, above commands are not enought –  zetah Feb 15 '12 at 15:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.