Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I recently bought a new Dell ultrabook with UEFI active. I want to install Ubuntu alongside Windows 8 so that I can dual boot between them. So I installed Ubuntu 12.10 (64-bit) on USB drive. After disabling the secure boot feature it allowed me to enter the boot menu in which I selected the USB flash drive (UEFI MODE). It gave me a black screen with the option to install Ubuntu in a clear white font.

When I selected the option the screen turned black, the LED on the usb drive started flashing and then stopped after a few seconds. Nothing happened. So I tried burning Ubuntu on a DVD. Same results.

I really want the dual booting option, and erasing Windows is unfortunately not an option. Has anybody got a solution to this problem? Thanks!

share|improve this question

marked as duplicate by Eliah Kagan, RolandiXor Sep 2 '13 at 17:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I recommend looking at this answer of a similar question. –  Dan Feb 26 '13 at 13:17

4 Answers 4

Exactly the same problem for me.

Dell Ultrabook Inspiron 14z. Ubuntu 64 bit Started from 4GB USB key I used unetbootin. I solved disabling UEFI protection and UEFI boot choosing legacy boot instead.

hope this can help

Pich

share|improve this answer

This is likely a hardware incompatibility issue. One thing that can help in some such cases is to add nomodeset to the kernel options. You do this from the GRUB screen (the one with the boot menu you mentioned) by using the arrow keys to select the option you want to use and then, rather than press Enter, press the E key. You can then edit the options. (The screen has prompts at the bottom for how to perform some common actions.)

If this doesn't help, I recommend you post more identifying information about your hardware, such as the laptop's exact model number and/or all the chipsets and other hardware components that make it up.


Edit: Since you say that booting in legacy mode works, I suggest you do the following:

  1. Install Ubuntu in legacy mode.
  2. Install my rEFInd boot manager. Installing it in Windows is preferable to installing it in Ubuntu; but installing it in Ubuntu will be easier, if you find the Windows installation instructions too intimidating.
  3. Edit the refind.conf file: Locate the scanfor line, uncomment it, and add hdbios to the list of options.
  4. Reconfigure the firmware to boot in EFI mode.

At this point, when you boot, you should see a rEFInd menu with a Windows option, one or more Linux options (which will probably be non-functional), and a gray generic icon. The generic boot option will probably launch GRUB in BIOS mode, which will then launch Ubuntu. If the Linux boot option(s) actually work, you can remove the hdbios option from the scanfor line in refind.conf; but if not, you can remove them by commenting out the scan_all_linux_kernels option instead.

share|improve this answer
    
I've tried the nomodeset option, but unfortunately it did not work: the screen kept being black. Booting the 'legacy' usb drive option works quite well, but it doesn't allow dual-booting. The laptop is a brand new Dell Inspiron 15z-5523 Ultrabook with SSD. –  Steve Feb 25 '13 at 21:15
    
Please see my new suggested solution. –  Rod Smith Feb 26 '13 at 17:55

I have the same problem with my AMD A10-4600M MSI GX60 netbook. I managed to install ubuntu but i had to replace original windows8 with other windows8 installed in Legacy mode so i could install ubuntu in legacy too. This solution is only temporary, till i find how to install ubuntu in UEFI :( I hope it helps you temporarily...

share|improve this answer

Same sort of situation here, also MSI gx60. I opted to just leave Windows on UEFI though and install Ubuntu on Legacy, I just go into the bios and change the boot method when I want to boot the other OS. I guess it takes a little longer to switch this way though.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.