Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I currently have Windows 7 - 64bit Professional on my PC. I tried to install 12.10 via USB and it worked OK, I partitioned my main C drive and restarted my PC after Ubuntu had installed.

On boot up I get this error:

Error: No such device: e80420c6-e74d-4211-8854-3ce6e2f8eb48.
Grub Rescue>

I now cannot log onto my PC, any advice would be great.

share|improve this question

Try to boot from a live cd. You must install grub boot loader again. Do as I say:

  1. Make a bootable usb disk and boot from it (in this way you will have a live ubuntu)
  2. Mount your previous ubuntu partition in any way you know (You can do this by opening filemanager and go to partition where your ubuntu is installed on, then copy the path to this partition)
  3. Then press Ctrl+Alt+T and open terminal, then run sudo grub-install --boot-directory=/path/to/mounted/folder/for/ubuntu/boot sda. (make sure that you typed sda and boot at the end). In my case this is like sudo grub-install --boot-directory=/media/76s876sd86d8f7sdfsdf/boot sda
share|improve this answer
Right, I'm afraid you've lost me there. Can you make your explanation more basic? – Benji Martin Feb 24 '13 at 14:41
Still trying to fix this I've managed to boot up ubuntu using my USB, I (believe) I have mounted the disk drives (although I'm not sure) But I can't find the directory to fix this problem. – Benji Martin Feb 24 '13 at 17:45
Thanks again Mostafa, I've loaded the terminal, typed sudo grab-install --boot- directory= (C:\media) sda but it doesn't work – Benji Martin Feb 24 '13 at 17:50
I do have live USB on, In the terminal I've typed "Sudo grub-install --boot-directory=/media/00768D01768CF924 sda I got the message Path 'media/00768D01768CF924/grub is not readable by GRUB on boot. Installation is impossible Aborting. – Benji Martin Feb 24 '13 at 18:00
Try this: sudo grub-install --boot-directory=/media/00768D01768CF924/boot sda – Mostafa Shahverdy Feb 24 '13 at 18:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.