Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Lenovo T400 and Ubuntu 10.10, I am using CPU Frequency Scaling Monitor 2.30.0 on the panel to show and control CPU frequency.

My CPU frequency by default will change according to load. But I want to make CPU work at the lowest level and so I choose 800 MHz in CPU Frequency Scaling Monitor. After a few seconds, however, it automatically changes back to Powersave or Performance mode which has automatic adjustment to CPU frequency.

I was wondering how to actually make CPU work at the lowest level? Thanks!

PS: On Acer Aspire 5000 and ubuntu 8.10, I can use CPU Frequency Scaling Monitor to control CPU frequency as I wish.

share|improve this question
1  
Sounds like a bug. Possibly this is relevant : bugs.launchpad.net/ubuntu/+source/cpufreqd/+bug/344252 –  Scaine Feb 13 '11 at 20:27
add comment

1 Answer 1

Follow the steps:

sudo apt-get install rcconf 
sudo rcconf

Search for

ondemand

option and disable(un-check the check-box) it using space-bar.

share|improve this answer
    
@Tim .. Usefull answer? –  Ilias el Matani Feb 14 '11 at 10:23
    
@Ilias el Matani: Thanks! It doesn't solve the problem, as CPU Frequency Scaling Monitor still shows the freq of one CPU is set to "Performance" instead of "Ondemand" and is automatically change, while that of the other CPU is fixed at 800 MHz. –  Tim Feb 14 '11 at 12:25
    
Looks like I can only control frequency of one of the two CPUs via CPU Frequency Scaling Monitor. –  Tim Feb 14 '11 at 12:47
    
I think the question is not clear for me. If you disable 'ondemand' in rcconf the frequency of your CPU is not automatically being changed? –  Ilias el Matani Feb 14 '11 at 15:07
1  
If I uncheck 'ondemand' in rcconf, the frequency of my CPUs is still automatically being changed. –  Tim Feb 15 '11 at 3:46
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.