Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a dell inspiron M301Z running with ubuntu 12.04. It used to run fine until I reinstalled it. It worked fine during the installation but when i downloaded the updates via updates manager the connection dropped. Now it keeps trying to connect to the network but fails each time. The connection is working on windows. In Additional drivers it shows the broadcom STA wireless driver as activated.

sudo lshw -C network
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 01
       serial: c4:46:19:95:cf:08
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:d0300000-d0303fff
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 04
       serial: 00:26:b9:70:33:62
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:a000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff

rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I have read a few posts on here and tried a few things but nothing worked.


share|improve this question

DNS problem, maybe?

Have you edited




My 12.04 wifi problems were fixed when I disabled iPv6 and edited /etc/network/interfaces to include just

auto lo
iface lo inet loopback

(Don't have to delete everything else, just ## comment out.)

share|improve this answer
Hi,Thanks for the reply – mae Feb 26 '13 at 9:08
but didn't work in my case – user702846 Sep 25 '13 at 10:35
To be honest, I had recurring network connection problems in 12.04 LTS, but am now using 13.04 and have yet to have a problem. Part of the process included installing a newer kernel so that may have been it. (I had a lot of other problems getting 13.04 to work, but network connection worked right away.) Maybe try upgrading kernel/headers? – nbm Sep 28 '13 at 3:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.