Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm starting up with Linux and having loads of issues. Already tried to find answers here, but can't make anything out of them.

I installed Ubuntu (64 bit version) on a partition of my W7 HHD and created a SWAP too, but W7 keeps on booting straight away. I do not get any Grub2 menu. As I do not have a CD device, I am using USB for everything.

I tried several things that I found here to fix it (besides right shift and Esc repeatedly):

Try Ubuntu without installing (after being installed) would not let me click on anything.

Burn a Live-CD on my USB, open a terminal and use:

sudo add-apt-repository ppa:yannubuntu/boot-repair

but it will say "command does not exist". Besides, it does not appear to recognize Ubuntu's installation. When I tried to use:

sudo install-grub

the system gives me a message saying if I'm sure if /dev is installed.

Burn a boot-repair USB and run it, but it says that I need internet access to complete the operation and repair grub2, and as I do not have a LAN connection I can´t do it either.

I also tried reinstalling and updating Ubuntu, downloading another iso just in case, but with similar results.

Any advice will be highly appreciated.

I have extracted the boot-repair info file, in case it helps for this issue.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Thanks to everyone!

I finally sorted it, after understanding a few things and doing:

Installing 11.10

Creating a Live-USB

running Live USB

installing and running boot-repair with:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get install boot-repair

 sudo apt-get update
  • GRUB came out here

selecting Ubuntu Classic/2D in login screen

  • Here I was able to click on things after

booting Ubuntu from my HDD

Updating

Restarting and selecting normal mode

share|improve this answer

If the boot menu did not come up, at boot keep on tapping the left-shift key. If grub2 comes up, then boot into Ubuntu.

Now grub has detected Ubuntu, but as soon as you reboot it will not find Ubuntu.

To fix this, load Terminal in Ubuntu and type in update -grub.

Hopefully when you reboot grub should be there.

Hope this helps!

share|improve this answer
    
It didn´t work, W7 loaded straight away again. Thanks anyway! –  Yinn Feb 24 '13 at 10:13
    
Hmm... you have a big problemo here... I can't test terminal commands, because I upgraded to Windows 7 yesterday! But I still answer people because of using Ubuntu for a long time. –  nerof61 Feb 24 '13 at 10:16

Probably the problem is that grub2 insatlled in the usb... (Happened to me) What you need is burn another Ubuntu x64 usb, and do not create it woth unetbooton, use better the one that Ubuntu.com/download recomenss you... ( there is a faq that says how to make a bootable usb) Next boot from it and try Ubuntu, open a terminal and install boot-repair

sudo apt-add-repository ppa:yannubuntu/boot-repair && sudo apt-get update

sudo apt-get install boot-repair && boot-repair

Then go for recommended repair, Boot-repair will ask you to open a new terminal and write some commands down... It will repair grub...

Good luck and don't make your computer explode! :D

share|improve this answer
    
Hehehe thanks, I´m trying very hard not to smash it to pieces. The thing is that I can´t do that. I already have a usb with boot repair and a Live-USB. I got a 12.04 iso and reinstalled but faced the same issues. If I select "Try Ubuntu" it will not let me click on anything, and the top bar is empty. With the 11.10 I could manage to actually enter ubuntu and tried with those commands, but it gave me errors so it didn´t work. I´ll keep on trying. –  Yinn Feb 24 '13 at 15:11
    
And now with the 12.04 I can´t even enter ubuntu. The menu will not accept any option... –  Yinn Feb 24 '13 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.