Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installing Roundcube Web Server, gave date and time error while checking PHP configuration. I am trying to configure the webamil using roundcube. Below is the details.

  1. pop / smtp service is working fine on my mail server.
  2. Able to send and receive mails through the mail client perfectly fine.
  3. Using plain text authentication.
  4. SSL or TLS is not used in mail server.
  5. Roundcube version: roundcubemail-0.8.5
  6. PHP Version: PHP 5.3.10
  7. Need to set timezone settings to Asia/Kolkata

I have checked this link and on thing I could understand out of it is that I need to modify the php.ini/.htaccess or just /.htaccess but could not find the /.htaccess in the installation folder of roundcube second I could find the php.ini/.htaccess @ /usr/local/lib/php.ini ... where I already modified it to date.timezone = "Asia/Kolkata" and restarted appache2 service still roundcube installation page shows below error.

Below is the complete page with the error in bold: Roundcube Webmail Installer

Check environmentCreate configTest config
Checking PHP version

Version: OK(PHP 5.3.10-1ubuntu3.5 detected)
Checking PHP extensions

The following modules/extensions are required to run Roundcube:

PCRE: OK
DOM: OK
Session: OK
XML: OK
JSON: OK
The next couple of extensions are optional and recommended to get the best performance:

FileInfo: OK
Libiconv: OK
Multibyte: OK
OpenSSL: OK
Mcrypt: OK
Intl: OK
Exif: OK
Checking available databases

Check which of the supported extensions are installed. At least one of them is required.

MySQL: OK
MySQLi: OK
PostgreSQL: NOT AVAILABLE(Not installed)
SQLite (v2): NOT AVAILABLE(Not installed)
Check for required 3rd party libs

This also checks if the include path is set correctly.

PEAR: OK
MDB2: OK
Net_SMTP: OK
Net_IDNA2: OK
Mail_mime: OK

Checking php.ini/.htaccess settings

The following settings are required to run Roundcube:

file_uploads: OK
session.auto_start: OK
zend.ze1_compatibility_mode: OK
mbstring.func_overload: OK
suhosin.session.encrypt: OK
magic_quotes_runtime: OK
magic_quotes_sybase: OK
*date.timezone: NOT OK(empty value detected) * The following settings are optional and recommended:

allow_url_fopen: OK
Sorry but your webserver does not meet the requirements for Roundcube!
Please install the missing modules or fix the php.ini settings according to the above check results.
Hint: only checks showing NOT OK need to be fixed.

Installer by the Roundcube Dev Team. Copyright © 2008-2012 – Published under the GNU Public License; Icons by famfamfam`

share|improve this question

1 Answer 1

up vote 6 down vote accepted

It's simple ....

  1. Edit /etc/php5/apache2/php.ini this file which is used for PHP configuration by Apache & add below line in it. This is the right php.info path for the Apache web server, otherwise use the respective web-server's folder in the /etc/php5/ location.

List of supported timezone in PHP click here.

date.timezone = "Asia/Kolkata"

Make sure that this line should not be commented. Remove comment ; from starting of line, otherwise it will not work.

  1. then Save and Exit.

  2. Now to check whether it is working or not please copy past below php code in a new index.php file and put that file in your web-root folder, which is /var/www/ by default unless you have changed it to some other.

<?php

// Show all information, defaults of PHP Configuration.

phpinfo();

?>
  1. then save and exit... make sure the file name is correct and it is in web-root.

  2. Then restart the Apache service using below command.

/etc/init.d/apache2 restart

  1. It will start working....

  2. Now open up a web browser and type http://localhost/path_of_your_index.php_file & then hit enter. This will show you all PHP related information & PHP configuration currently active. This page is known as PHP info Page.

and on this PHP info page... check the below screen shot which is that part of PHP info page which shows the currently loaded PHP date and time settings.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.