Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is Dell Inspiron 15R. I have installed Ubuntu 12.10 a week ago, and realized that the option for wireless is not there. Not even in the network settings, so I went through the problems posted earlier and I thought its because of Broadcom. So I tried:

sudo apt-get update  
sudo apt-get install b43-fwcutter

But still the wifi is not working.

When I typed rfkill list all in the terminal I got the following output...

0: hci0: Bluetooth  
Soft blocked: yes  
Hard blocked: no  

It's showing me only bluetooth and nothing about wireless. I guess wireless is blocked somewhere.

Please help...

share|improve this question
add comment

2 Answers

follow the below link, It may be usefull..... :) http://technotranz.blogspot.in/2013/02/ubuntu-1210-wireless-problem-solved.html

share|improve this answer
    
Software sources is also not showing me the Broadcom option....I can't upload the photo of the software sources because I don't have much reputations.... –  REGZEN Feb 24 '13 at 17:35
add comment

By typing the command :

lspci

You can check what kind of wireless card your Dell Inspiron 15R have. I guess it's probably something like bcm43xx.

If so, the answer to get your wifi working is :

sudo apt-get install linux linux-headers-generic kernel-package
sudo apt-get purge b43-fwcutter firmware-b43-installer firmware-b43-lpphy-installer firmware-b43legacy-installer bcmwl*
sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer bcmwl*

Reboot !

You can also try a sudo rfkill unblock all it helped me once with my inspiron 15R.

From this post on askubuntu.com

share|improve this answer
    
Its still not working.. :( –  REGZEN Feb 24 '13 at 17:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.