Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am supposed to fix a laptop in which the hard disk was recently formatted. It contained Windows 7 before. I am trying a fresh install of ubuntu 12.04 from a bootable USB, but haven't been able to go past the maintenance shell. In the maintenance shell, I tried out the following:

root@ubuntu:~# ntfsfix -b -d /dev/sda
Failed to determine whether /dev/sda is mounted: No such file or directory
Mounting volume... NTFS signature is missing.
FAILED
Attempting to correct errors... NTFS signature is missing/
FAILED
Failed to startup volume: Invalid argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk

The trouble may be that there aren't permissions to write on the ntfs partition. The partition might not be corrupt. When I check the filesystem, I get this:

root@ubuntu:~# fsck /dev/sda
fsck from util-linux 2.20.1
ext2fs_check_if_mount: Can't check if mounted due to missing mtab file while determining whether /dev/sda is mounted. Bad magic number in super-block 
The superblock could not be read or does not describe a correct ext2 filesystem.

So, it must be an ntfs file system. that's why I tried ntfsfix but that didn't work. The hard disk is not partitioned. When I run

fdisk -l

it shows /dev/sda (~500 GB) and /dev/sdb (boot recovery) . I have been trying to run

badblocks -v /dev/sda 

But, suddenly the laptop just reboots and I don't even get to the maintenance shell stage. I select "Install ubuntu" and it gets stuck at the wait screen forever. Please help!

share|improve this question

1 Answer 1

Try /dev/sdaX --> X is a number from 1 to n.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.