Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Several months ago I installed Ubuntu in an external 500MB USB disk (and on an old MacBook4,1). with a GPT Partition table and partitioned as following:

  • swap
  • swap
  • an unique ext4 partition for Ubuntu
  • one NTFS partition for datas

Everything worked fine with Grub on sda (a 500MB disk with standard osx installation and partitions).

Some days ago I installed another distro in another USB disk, also with GPT:

  • a couple NTFS partitions
  • swap
  • swap
  • unformatted 12 MB flagged as bios_grub
  • root
  • var
  • home

and installed this Grub in the external disk. Both installations does not rely on EFI to boot.

When I tried to boot the new installation a message always complained about the lack of the other partition (Ubuntu) so I did a backup and cleared the MBR.

sudo dd if=/dev/zero of=/dev/sda bs=446 count=1

Short story, after clearing (and also after restoring) the MBR I am not anymore able to boot Ubuntu and when trying to reinstall Grub from the LIVE CD I get the following message:

/usr/bin/grub-setup: warn: This GPT partition label has no BIOS Boot Partition, embedding won't be possible.

/usr/bin/grub-setup: error: embedding is not possible, but this is required fro cross-disk install. 

Well, how Grub installed originally at Ubuntu installation time? There is something different from grub-install procedure?

Both Ubuntu (I've installed a Grub also in it) and the other distro boot fine on another computer, but after reading a lot of posts here and there nothing worked for me and I am really confused:

how can I restore the Grub and let both disk to boot?

Without to say that I am afraid that trying the EFI way would produce nasty effects.

share|improve this question
    
Btw, I see that the question got a -1, does not show any research effort: that's simply not true. There are days that I am reading posts here and there, without find a good solution. So, if you don't know how to answer, don't judge please. –  Max Feb 24 '13 at 16:26
add comment

1 Answer

I did an AHT (Hardware text) extended. Looks like the internal controller is defective (4HDD/11/40000004:SATA(0:0) and after some time causes an invalid node structure.

I think the issue is raised from the controller malfunction (HD imminent failure is a consequence) and probably leads to my issue trying to install Grub:

it is not possible to install anything not to be that you reformat the hard drive, procedure that temporarily restores the functionality of the disc.

After formatting I was able to install Grub.

Long time solution: replace the controller (or the computer).

share|improve this answer
    
Thank you to the down voter for pointing intelligently out the root cause. –  Max Feb 25 '13 at 14:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.