Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

It appears that Unity on Raring only comes with a single virtual desktop (aka workspaces) by default, and CCSM's Wall plugin has no way to add more. Is this configurable at all?

share|improve this question

6 Answers 6

up vote 288 down vote

for 13.04 and later..

Workspaces are disabled by default in Ubuntu since 13.04. To enable them, open Appearance from the dash:

enter image description here

Switch to the behaviour tab and check "Enable Workspaces".

enter image description here

If you want to hide the workspace switcher see this question.

share|improve this answer

Using the Dash or a terminal, open the dconf-editor application. Navigate to


And set the horizontal and vertical dimensions of your wall. A workspace switcher will immediately appear on the launcher. You can use this or Super-s to view the virtual desktops / workspaces.


To set this using command-line, execute the command:

gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ hsize 2

This will immediately enable workspaces. This command will actually set hsize to 2 and vsize to 2, giving you 4 workspaces arranged in a square, which is the default when you enable workspaces from the GUI "Appearance" setting.

share|improve this answer
I've never used this command before but at least as of 14.04 you have to set hsize and vsize, running the command twice, to get the 2x2 default workspaces. Otherwise, thank you, this worked perfectly. =) –  Tony Apr 18 '14 at 16:49

Ubuntu 13.04 Raring Ringtail will come with workspaces disabled by default, so before being able to switch between them go to "System Settings..." > "Appearance" and switch to "Behavior" tab, then it is just to check "Enable Workspaces" option and you will have back your 4 workspaces.

Ctrl+Alt+Arrow will change current workspace and Shift+Ctrl+Alt+Arrow will change the current focused window to the desired workspace.

You can see a list of all the shortcuts of Ubuntu from "System Settings..." > "Keyboard" then switch to "Keyboard Shortcuts" tab and then you will be able, beyond to see all of them, to change them and create new shortcuts.

share|improve this answer
I want to use ctrl+alt+arrow but nothing append when I press these keys. –  user158304 May 13 '13 at 13:40
@user158304 before you need to enable workspaces in Raring, so just follow the steps I added to the beginning of my question. –  Rodrigo Martins May 13 '13 at 13:43
smile i was thinking the same ....workspace is not enabled –  Qasim May 13 '13 at 13:45
I already enabled workspace and I'm using them. But I only can switch using the icon and not the shortcut Ctrl+Alt+Arrow. However, the shortcut "Super"+s is working. –  user158304 May 13 '13 at 14:06
@user158304 Have you tried both Ctrl keys in your keyboard, or other Alt key if there is other? Also try going to "System Settings..." > "Keyboard", switch to "Keyboard Shortcuts" tab and see what shortcut is set to switch workspaces. –  Rodrigo Martins May 13 '13 at 14:11

This may be new since Alaa answered, but there is also a graphical way of adjusting the number of workspaces when you have compiz installed.

Open CompizConfig Settings Manager (installs from the Ubuntu Software Centre if not already installed), then under "General", click "General Options" and go to the "Desktop Size" tab. This will automatically enable workspaces and gives you the ability to adjust it as you like. I personally like 4 horizontal, 1 vertical. It's really cool with desktop cube enabled.

share|improve this answer

You can also install the Unity Tweak Tool, using it you can customize many aspects of the unity interface, including the number of workspaces. You can install it using the following repository:

sudo apt-get install unity-tweak-tool

Then you just open the Unity Tweak Tool, go to Window Manager/Workspace Settings and so you can choose as many workspaces as you wish. I like to use it because I can set workspaces to be not just on the horizontal but on the vertical as well.

enter image description here

share|improve this answer
you no longer need a ppa for this –  mchid Sep 23 at 5:56


first, open ccsm. If it's not installed, run: sudo apt-get install compizconfig-settings-manager

Next, you will find the setting in the General Options section, under the Desktop Size tab.

Here you will see options for your Horizontal Virtual Size and Vertical Virtual Size.

Increase the Horizontal Virtual Size to a value >1.

Use CTRL + ALT + right arrow to move one virtual desktop to the right and CTRL + ALT + left arrow to move one desktop to the left.

share|improve this answer

protected by Community Oct 14 '13 at 12:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.