Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep getting this error when I try running sudo apt-get install nvidia-current:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-current : Depends: xorg-video-abi-11
                  Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

How do I fix this?

share|improve this question
    
have you tried with sudo apt-get install -f –  AgentCool Feb 24 '13 at 3:14
    
The following packages were automatically installed and are no longer required: dkms linux-headers-3.5.0-23 linux-headers-3.5.0-18 linux-headers-3.5.0-23-generic linux-headers-3.5.0-18-generic Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. –  Feders Feb 24 '13 at 3:17
    
Nothing changed after sudo apt-get autoremove, apart from removing the non-required packages. –  Feders Feb 24 '13 at 3:19
    
do this sudo apt-get install xorg-video-abi-11 xserver-xorg-core –  AgentCool Feb 24 '13 at 3:21
    
I can put more info in my answer if you list your specific graphics card name (: –  Richard Feb 24 '13 at 4:03

2 Answers 2

This problem arises from an Xorg/nVidia bug where nVidia's driver is incompatible with some of the code in the latest Xorg version. You can try installing the drivers with Software Sources (Additional Drivers tab), or jockey-text in the terminal (which you can learn how to use with a quick Google search or jockey-text --help), or by checking for your drivers at the nVidia website at http://www.geforce.com/drivers (use the Manual Driver Search). Installing the drivers using apt will not work until the issue is fixed sometime in the future.

If you need instructions for installing drivers from nVidia's website, follow the guide here: https://help.ubuntu.com/community/NvidiaManual

share|improve this answer

As noted by 'rajagenupula' user. Special thanks to 'rajagenupula' user

Install older (12.04.1) version of xserver and you can install cuda with with the necessary driver (apt package nvidia-current).

sudo apt-get install xorg-video-abi-11 xserver-xorg-core

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.